tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Douglass <dou...@rpi.edu>
Subject Missing configuration resource /WEB-INF/struts-config.xml
Date Wed, 03 Oct 2001 13:23:27 GMT
I'm trying to get a combination of struts (1.0), tomcat 4 rc2 and kerb 5 
working.

I've got security enabled and I'm getting the message
Missing configuration resource for path /WEB-INF/struts-config.xml

  I've tried moving the struts config file about and changing the config 
parameter in web.xml but no luck at all.

It sort of worked with tomcat4 b5 but authentication with forms wasn't 
working so I moved to rc2.

I tried turning security off again and it finds the file OK so it looks 
like the WebappClassLoader (???) has no access to the file.

Any ideas where I should go from here? Is it just a matter of modifying 
catalina.policy? Shouldn't it have read access by default to the /WEB-INF 
directory? Do I have to specify every webapps access specifically?

Also, where do I set a non-zero debug value to see logging from the webapp 
loader? I set them all to non-zero in server.xml and extra output didn't 
appear.

Mike Douglass				douglm@rpi.edu
Senior Systems Programmer	
Communication & Collaboration Technologies	518 276 6780(voice) 2809 (fax)
Rensselaer Polytechnic Institute 110 8th Street, Troy, NY 12180


Mime
View raw message