tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eq <edward.qu...@btinternet.com>
Subject Cannot load mod_webapp.so into server: __lshrdi3: reference symbol not found
Date Mon, 15 Oct 2001 16:06:09 GMT

Hi,

I'm trying to get mod_webapp to work so that I can use Tomcat 4.0 with
Apache 1.3.20. I'm using Solaris 8 on Sparc 5 and I've built apache with
a Sun C compiler, and I'm using the Tomcat binary.

If I use the binary from:

http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0/bin/

I get the following message when I do apachectl configtest:

Syntax error on line 206 of /usr/local/apache/conf/httpd.conf
Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/mod_webapp.so: symbol __lshrdi3: referenced
symbol not found


If I try to build the module, the configure part works fine, but when I
get to the make I get a lot of errors related to pr_warp.c:

pr_warp.c: In function `headers':
pr_warp.c:198: `TYPE_REQ_HEADER' undeclared (first use in this
function)
pr_warp.c:198: (Each undeclared identifier is reported only once
pr_warp.c:198: for each function it appears in.)
pr_warp.c: In function `warp_handle':
pr_warp.c:245: `TYPE_REQ_INIT' undeclared (first use in this function)
pr_warp.c:279: `TYPE_REQ_CONTENT' undeclared (first use in this
function)
pr_warp.c:291: `TYPE_REQ_SCHEME' undeclared (first use in this
function)

etc etc

Could someone help me out please? gcc is not an option for me either.

Thanks,

Ed.





Mime
View raw message