tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: mod_webapp - no config variable LDFLAGS_SHLIB
Date Mon, 15 Oct 2001 13:00:25 GMT
Dan Silcox wrote:
> 
> I'm trying to compile on Redhat Linux 7.0 with apache 1.3.19 and gcc version
> 2.96 with the latest from the cvs repository.
> 
> ./configure --with-apxs=/usr/local/apache/bin/apxs
> .
> successful, now run make - good luck
> make
> .
> 
> make[1]: Entering directory "apache-1.3"
> make[1]: Invoking "make  build"
> make[2]: Entering directory
> `/tmp/jakarta-tomcat-connectors/webapp/apache-1.3'
> { APXS_LDFLAGS_SHLIB="`/usr/local/apache/bin/apxs -q LDFLAGS_SHLIB` \
>          \
>         -lm -lcrypt -lnsl -ldl" ; \
>     APXS_LDFLAGS_SHLIB=`/bin/echo ${APXS_LDFLAGS_SHLIB}` ; \
>     APXS_CFLAGS="`/usr/local/apache/bin/apxs -q CFLAGS` \
>         -g -O2 \
>         -g -O2 \
>          \
>         -DLINUX=2 -D_REENTRANT \
>         -I/tmp/jakarta-tomcat-connectors/webapp/apr/include \
>         -I/tmp/jakarta-tomcat-connectors/webapp/include \
>         " ; \
>     APXS_CFLAGS=`/bin/echo ${APXS_CFLAGS}` ; \
>     /usr/local/apache/bin/apxs \
>         -S CFLAGS="${APXS_CFLAGS}" \
>         -S LDFLAGS_SHLIB="${APXS_LDFLAGS_SHLIB}" \
>         -o "mod_webapp.so" \
>         -c "mod_webapp.c" \
>         "/tmp/jakarta-tomcat-connectors/webapp/lib/libwebapp.a" \
>         "/tmp/jakarta-tomcat-connectors/webapp/lib/libapr.a" ; \
> }
> apxs:Error: no config variable LDFLAGS_SHLIB

Mine tells "-G".

What does /usr/local/apache/bin/httpd -l says?

Mime
View raw message