tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Ward <david.w...@dotech.com>
Subject Re: mod_webapp connector on linux - HELP!
Date Thu, 04 Oct 2001 23:07:52 GMT
Actually, you DON'T have to define your context(s) within VirtualHost 
directives.  I was finally able to get mod_webapp working against 
standalone catalina (but not with jboss/catalina).

What I had to do was this:
1) drop mod_webapp.so in my modules directory
2) make sure ServerName localhost was UNcommented
3) put my "LoadModule webapp_module modules/mod_webapp.so" line at the 
end of my already existing LoadModule list
4) put my "AddModule mod_webapp.c" line at the end of my already 
existing AddModule list
5) put my "<IfModule mod_webapp.c>
WebAppConnection comm warp localhost:8008
WebAppDeploy examples conn /examples
WebAppInfo /webapp-info
</IfModule>" block at the end of the file

It seemed that where I put my LoadModule and AddModule directives was 
important.  Putting them at the bottom of httpd.conf right over my 
<IfModule...> didn't work.  doing an "include" didn't work either.  I 
had to separate them for some weird reason.

I'll attach my *working* httpd.conf file so people can use it to compare 
with.

David

PS: I'm still looking forward to seeing a mod_webapp-eapi.so release...

--

John Cartwright wrote:

> James,
> 
> I'm confused about what goes in the <virtualhost> section. Do my
> WebAppConnection and WebAppDeploy go there?  Can you point me to an
> example - something like "Tomcat4-Apache.HowTo"
> 
> Thanks!
> 
> -- john
> 
> 
> James Williamson wrote:
> 
>>>Actually, I am not setting up virtual hosts like you are, so the
>>>mod_webapp result of application deployment *should* be localhost
>>>(what's set as my ServerName), right?
>>>
>>David,
>>
>>You have to define your context(s) within VirtualHost directives.
>>
>>Regards,
>>
>>James
>>
>>
>>>My apache error_log looks like this on startup:
>>>
>>>[Wed Oct  3 13:22:25 2001] [warn] Loaded DSO modules/mod_webapp.so uses
>>>
>>plain Apache 1.3 API, this module might crash under EAPI! (please recompile
>>it with -DEAPI)
>>
>>>[Wed Oct  3 13:22:25 2001] [error] Connection "conn" cannot connect
>>>[Wed Oct  3 13:22:25 2001] [error] Cannot open connection "conn"
>>>[Wed Oct  3 13:22:25 2001] [error] Connection "conn" cannot connect
>>>[Wed Oct  3 13:22:25 2001] [error] Cannot open connection "conn"
>>>[Wed Oct  3 13:22:25 2001] [error] Connection "conn" cannot connect
>>>[Wed Oct  3 13:22:25 2001] [error] Cannot open connection "conn"
>>>[Wed Oct  3 13:22:25 2001] [error] Connection "conn" cannot connect
>>>[Wed Oct  3 13:22:25 2001] [error] Cannot open connection "conn"
>>>[Wed Oct  3 13:22:25 2001] [error] Connection "conn" cannot connect
>>>[Wed Oct  3 13:22:25 2001] [error] Cannot open connection "conn"
>>>
> 


-- 

-----------------------------------------------------------------------
David Ward                                        david.ward@dotech.com
Senior Software Engineer                          http://www.dotech.com
Distributed Object Technologies, Inc.             716-381-8320 (phone)
500 Linden Oaks, Rochester, NY 14625              716-381-0598 (fax)

Mime
View raw message