tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Chakmamkian <gregc...@mac.com>
Subject Re: Tomcat 4.0 on Mac OS X
Date Wed, 10 Oct 2001 12:12:17 GMT
Hi Ian.  I'm trying to take this step by step with upgrading from 3.2.2. 
to 4.  I have tomcat running in stand-alone mode, and get the same 
errors.  I haven't tracked it down yet.  I posted a similar message to 
this over the weekend and didn't get any response.  I'll let you know if 
I find anything.  I've also had problems getting mod_webapp.so to work 
with Apache.    When I test the configuration, I get the following:

  root# apachectl configtest
Syntax error on line 242 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/mod_webapp.so into server: (reason unknown)

Then again I've also heard that it might be better to use mod_jk for a 
while until mod_webapp gets a little more finalized.  Let me know if  
you make any progress and I'll do the same.   BTW, have you gotten the 
10.1 upgrade yet?  Its pretty nice.  I highly recommend it.

-greg



On Tuesday, October 9, 2001, at 07:31 PM, Ian Blakey wrote:

> I am attempting to run Tomcat 4.0 on Mac OS 10.0.4 (Build 4Q12)
>
> I downloaded the binaries, installed and run startup.sh.
>
> All seems OK when viewing the index page of the ROOT webapp but when 
> attempting to view the examples provided the page returned gives a 404 
> webbapp not available error and the log file 
> "localhost_examples_log.2001-10-09.txt" contains the following 
> exception:
>
> 2001-10-09 16:11:00 StandardContext[/examples]: Exception starting 
> filter Set Character Encoding
> java.lang.ClassNotFoundException: filters.SetCharacterEncodingFilter
> 	at 
> org.apache.catalina.loader.WebappClassLoader.loadClass
> (WebappClassLoader.java:
> 1264)
> 	at 
> org.apache.catalina.loader.WebappClassLoader.loadClass
> (WebappClassLoader.java:
> 1113)
> 	at org.apache.catalina.core.ApplicationFilterConfig.getFilter
> (ApplicationFilterConfig.java:252)
> 	at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef
> (ApplicationFilterConfig.java:314)
> 	at org.apache.catalina.core.ApplicationFilterConfig.<init>
> (ApplicationFilterConfig.java:120)
> 	at 
> org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:
> 3090)
> 	at 
> org.apache.catalina.core.StandardContext.start(StandardContext.java:3389)
> 	at 
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1123)
> 	at 
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1123)
> 	at 
> org.apache.catalina.core.StandardEngine.start(StandardEngine.java:307)
> 	at 
> org.apache.catalina.core.StandardService.start(StandardService.java:388)
> 	at 
> org.apache.catalina.core.StandardServer.start(StandardServer.java:505)
> 	at org.apache.catalina.startup.Catalina.start(Catalina.java:776)
> 	at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> 	at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> 	at java.lang.reflect.Method.invoke(Native Method)
> 	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:218)
>
> 2001-10-09 16:11:00 StandardContext[/examples]: Context startup failed 
> due to previous errors
> 2001-10-09 17:21:01 SessionListener: contextDestroyed()
> 2001-10-09 17:21:01 ContextListener: contextDestroyed()
>
>
> Has anyone an idea of what is missing or what I am missing?
>
> Cheers,
> Ian


Mime
View raw message