tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Williamson" <ja...@nameonthenet.co.uk>
Subject Re: mod_webapp connector on linux
Date Wed, 03 Oct 2001 07:55:43 GMT
You need to deploy your contexts inside 'VirtualHost' directives in Apache.

James


----- Original Message ----- 
From: John Cartwright <jcartwright@ngdc.noaa.gov>
To: Tomcat User Mailing List <tomcat-user@jakarta.apache.org>
Sent: Tuesday, October 02, 2001 5:08 PM
Subject: mod_webapp connector on linux


> Hello All,
> 
> I'm trying to establish a connection between apache 1.3.20 and tomcat4
> using the binary distribution of the mod_webapp connector.
> 
> I added the following lines to my httpd.conf file via Include directive:
> 
> LoadModule webapp_module modules/mod_webapp.so
> AddModule mod_webapp.c
> WebAppConnection conn      warp  localhost:8887
> WebAppDeploy     examples  conn  /examples4
> WebAppInfo /webapp-info
> 
> Tomcat4 is up and seems to be running fine.  However, when I try to
> start apache, I get:
> 
> Starting httpd: [Tue Oct  2 09:49:36 2001] [warn] Loaded DSO
> modules/mod_webapp.so uses plain Apache 1.3 API, this module might crash
> under EAPI! (please recompile it with -DEAPI)
> Syntax error on line 4 of /var/tomcat4/conf/mod_webapp.conf:
> Invalid virtual host name
> 
> This machine is:
> Red Hat Linux release 7.1 (Seawolf)
> Kernel 2.4.3-12smp on a 2-processor i686
> 
> Can someone direct me to what I'm doing wrong?
> 
> Thanks!
> 
> -- john
> 
>  
> =====================================================
> John Cartwright
> Professional Research Assistant / Associate Scientist
> CIRES, SEG/NGDC/NOAA
> (303) 497-6284
> jcartwright@ngdc.noaa.gov
> =====================================================
> 


Mime
View raw message