tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Lee" <tech_supp...@uls.com>
Subject Re: Anyone using javaservice with tomcat?
Date Wed, 10 Oct 2001 21:38:30 GMT
I'm not sure what the problem could be... When i was trying to first set up
Tomcat 4, it would beep as well after a few seconds, but that's because i
didn't try using the installtomcat4.bat file but used my own.

I did play with 323, but due to some constraints and differences with
JavaWebServer, i decided to up to 4.  So i didn't really get to work with
323 much, so i don't know what the problem could be.

I could suggest a few things.
1. Upgrade your JDK to 1.31_01.
2. Upgrade tomcat to 4.  (But there are some configuration and changes
required with servlets, and locations of servlets.  I can try and help in
that case.)

Sorry I can't help any further, but I tried. :)

...Robin

----- Original Message -----
From: "Chris Gross" <cgross@chessys.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Wednesday, October 10, 2001 3:04 PM
Subject: RE: Anyone using javaservice with tomcat?


>
> Hi Robin, Thanks for the response.
>
> Actually I'm using 3.2.3 on win2k.  I've done steps similar to what you
> said.  I grabbed all my classpath entries and put them in the
> "-Djava.class.path=" option in the installtomcat32.bat.  Then ran
> "installtomcat32 c:\jdk1.3 c:\jakart~1.3".  It says it install the service
> successfully and I don't see any errors.  The service starts fine.  It
does
> beep after about 3 seconds which is weird.  The stderr.log and all the
other
> log files are empty or show normal status.  But when I try to connect to
> http://localhost:8080 my web browser just hangs.  No response after 10
> minutes...
>
> I am using direct SSL with tomcat and jdk 1.3 (not 1.3.1)...
>
> -chris
>
> -----Original Message-----
> From: Robin Lee [mailto:tech_support@uls.com]
> Sent: Wednesday, October 10, 2001 4:18 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Re: Anyone using javaservice with tomcat?
>
>
> I have... It was only yesterday that i got it to work. I assume you are
> using jdk1.31_01 and tomcat 4.
>
> What I had to do was set the following up in the system variables.
>
> JAVA_HOME (d:\jdk1.3.1_01)
> CATALINA_HOME (d:\tomcat)
> CATALINA_BIN (not sure if it was needed, so i included it anyway). (same
as
> catalina_home)
> CLASSPATH (this classpath is what is defaulted when you run the startup
> script for tomcat)
>     "d:\tomcat\bin\bootstrap.jar;d:\jdk1.3.1_01\lib\tools.jar"
>
> Then i created a batch file that loads the "installtomcat4.bat" file.
> installtomcat4 %JAVA_HOME% %CATALINA_HOME% classic
>
> Thus, as you can see, javahome and catalinahome are used from the system
> variables.  classic, well... That one worked for me and i've decided to
keep
> it.  I still don't know the diff between the classic, server and hotspot
(if
> anyone knows, can ya let me know if possible? :)
>
> Once i run the new batch file, it'll save it into the services for me (my
> case is win2k, but i have 2 servers with winnt), then I ran the service.
>
> I then logged off the server, and went to another workstation to see if it
> would work.  It certainly did.
>
> I hope this helps.  Let me know if you have any problems.
>
> ...Robin
> ----- Original Message -----
> From: "Chris Gross" <cgross@chessys.com>
> To: "tomcatlist" <tomcat-user@jakarta.apache.org>
> Sent: Wednesday, October 10, 2001 1:38 PM
> Subject: Anyone using javaservice with tomcat?
>
>
> >
> > http://www.alexandriasc.com/software/JavaService/index.html
> >
> > Apparently it was created because the author needed to run Tomcat as a
> > service with jdk 1.3.  I had to play around with it a little so that the
> > service would startup.  I had to change the classpath parameter to
include
> > the JSSE jars for SSL and tomcat\classes directory for my interceptor.
> > After doing that I got the service to start successfully but my pages
> won't
> > load.  None of them.  http://localhost:8080 and my little globe just
keeps
> > on spinning without ever returning a 404 or anything (at least for a few
> > minutes before I finally hit cancel).
> >
> > Has anyone used javaservice and got it working?
> >
> > -chris
>


Mime
View raw message