tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikola Milutinovic" <>
Subject Error deploying application
Date Tue, 09 Oct 2001 17:38:30 GMT
Hi all.

It's me again. As you've already guessed, I'm new to mod_webapp usage :-) Although I like
the idea. Anyway, I'm trying to deploy a web application on a virutal host Apache setup. I'm
getting an error:

2001-10-09 14:26:29 [org.apache.catalina.connector.warp.WarpConfigurationHandler] 
java.lang.IllegalArgumentException: addChild:  Child name '' is not unique

This is the setup, so far:

LoadModule webapp_module libexec/
AddModule mod_webapp.c

<IfModule mod_webapp.c>
        WebAppConnection tomcat4 warp localhost:8008


    DocumentRoot    /usr/users/mercury/public_html
    ErrorLog        /usr/users/mercury/logs/error.log
    CustomLog       /usr/users/mercury/logs/access.log common
    <IfModule mod_alias.c>
        ScriptAlias /cgi-bin/ "/usr/users/mercury/cgi-bin/"
    <IfModule mod_webapp.c>
        WebAppDeploy addr_book tomcat4 /addr_book/

I suspect that this config is OK. Tomcat's "server.xml" has both "standalone" and "warp" services,
with respective Connectors. Inside both of these, there are <Host ...> declarations
and I suspect that might be the problem. Should I remove:

<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true">

from "Standalone" service? That is supposed to be "default" host and I cannot access it on
port 8080.

Anyone got a hint for a real virtual host setup under Tomcat 4.0?

View raw message