tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Stoer" <marcel.st...@bluewin.ch>
Subject Re: tomcat ajp13 errors(henri where are you?)
Date Thu, 11 Oct 2001 08:56:01 GMT
[...]

> No there is a TC 4.0 service, WARP, called Tomcat-Apache, which
> use the warp protocol to link a web-server implementing warp,
> only Apache 1.3/2.0 for now and Tomcat 4.0.
>
> The Apache module for warp is called mod_webapp.
>
> mod_jk is also a WEB-SERVER module which does the link but
> it's work on Apaches, IIS, Nes.
>
> You should take a look at mod_jk documentation for using
> mod_jk in IIS :
>
> http://jakarta.apache.org/tomcat/tomcat-3.3-doc/tomcat-iis-howto.html
>
> To get the IIS up to date module, go to
>
>
http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.3-rc1/bin/win32/i
> 386/
>
> and get isapi_redirect.dll
>
[...]

Henri,

Thanks for the info about mod_jk.
I did all of this. Please take a look at my original posting below...

I hope you're able to help me..

Thanks, Marcel


> >> -----Original Message-----
> >> From: Marcel Stoer [mailto:marcel@frightanic.com]
> >> Sent: Tuesday, October 09, 2001 7:36 PM
> >> To: GOMEZ Henri
> >> Cc: tomcat-user@jakarta.apache.org
> >> Subject: tomcat ajp13 errors(henri where are you?)
> >>
> >>
> >> Hi all
> >>
> >> I've set up Tomcat 4.0 with IIS 5.0 and both servers run perfectly as
> >> individuals (examples work). And now... integrating
> >>
> >> Henri Gomez offers files
> (http://jakarta.apache.org/~hgomez/ajp13-tc4.0/)
> > and instructions for ajp13 and Tomcat 4.0. So, I followed his
instructions
> > and afterwards the tc3.3 - iis howto
> > (http://jakarta.apache.org/tomcat/tomcat-3.3-doc/tomcat-iis-howto.html)
.
> > HOWEVER, I must have made a minor but crucial mistake during the setup.
> All
> > checks (in howto) seem to be fine.
> >
> > iis log:
> > 19:12:24 127.0.0.1 GET /jakarta/isapi_redirect.dll 500
> >
> > isapi log:
> > [jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
> > [jk_ajp13_worker.c (174)]: In jk_endpoint_t::connect_to_tomcat, failed
> errno
> > = 61
> > [jk_ajp13_worker.c (587)]: Error connecting to the Tomcat process.
> > [jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
> >
> > in workers.properties:
> > worker.ajp13.port=8009
> > worker.ajp13.host=localhost
> > worker.ajp13.type=ajp13
> >
> > in uriworkermap.properties:
> > /servlet/*=ajp13
> > /examples/*=ajp13
> >
> > in server.xml:
> > <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" port="8009"
> > minProcessors="5" maxProcessors="75" acceptCount="10" debug="0" />
> >
> >
> > Any hints greatly appreciated!!
> > Cheers, Marcel


Mime
View raw message