tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Lee" <tech_supp...@uls.com>
Subject Re: Anyone using javaservice with tomcat?
Date Wed, 10 Oct 2001 20:17:41 GMT
I have... It was only yesterday that i got it to work. I assume you are
using jdk1.31_01 and tomcat 4.

What I had to do was set the following up in the system variables.

JAVA_HOME (d:\jdk1.3.1_01)
CATALINA_HOME (d:\tomcat)
CATALINA_BIN (not sure if it was needed, so i included it anyway). (same as
catalina_home)
CLASSPATH (this classpath is what is defaulted when you run the startup
script for tomcat)
    "d:\tomcat\bin\bootstrap.jar;d:\jdk1.3.1_01\lib\tools.jar"

Then i created a batch file that loads the "installtomcat4.bat" file.
installtomcat4 %JAVA_HOME% %CATALINA_HOME% classic

Thus, as you can see, javahome and catalinahome are used from the system
variables.  classic, well... That one worked for me and i've decided to keep
it.  I still don't know the diff between the classic, server and hotspot (if
anyone knows, can ya let me know if possible? :)

Once i run the new batch file, it'll save it into the services for me (my
case is win2k, but i have 2 servers with winnt), then I ran the service.

I then logged off the server, and went to another workstation to see if it
would work.  It certainly did.

I hope this helps.  Let me know if you have any problems.

...Robin
----- Original Message -----
From: "Chris Gross" <cgross@chessys.com>
To: "tomcatlist" <tomcat-user@jakarta.apache.org>
Sent: Wednesday, October 10, 2001 1:38 PM
Subject: Anyone using javaservice with tomcat?


>
> http://www.alexandriasc.com/software/JavaService/index.html
>
> Apparently it was created because the author needed to run Tomcat as a
> service with jdk 1.3.  I had to play around with it a little so that the
> service would startup.  I had to change the classpath parameter to include
> the JSSE jars for SSL and tomcat\classes directory for my interceptor.
> After doing that I got the service to start successfully but my pages
won't
> load.  None of them.  http://localhost:8080 and my little globe just keeps
> on spinning without ever returning a 404 or anything (at least for a few
> minutes before I finally hit cancel).
>
> Has anyone used javaservice and got it working?
>
> -chris


Mime
View raw message