tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Gokey <cgo...@gcmd.gsfc.nasa.gov>
Subject servlet mapping not recognized
Date Wed, 05 Sep 2001 01:01:00 GMT
HI everyone,

I just downloaded and installed Tomcat 3.2.3 and trying to setup a servlet
mapping.  For some reason it does not recognize my mapping at all.   Here
is what I added to web.xml:

     <servlet>
         <servlet-name>PyServlet</servlet-name>
         <servlet-class>org.python.util.PyServlet</servlet-class>
         <init-param>
             <param-name>python.home</param-name>
             <param-value>/home/mddevel/MD8_Devel/MD8/packages/jython</param-value>
         </init-param>
     </servlet>
     <servlet-mapping>
         <servlet-name>PyServlet</servlet-name>
         <url-pattern>*.py</url-pattern>
     </servlet-mapping>

Instead of mapping the .py file through the PyServlet class, it will just
display the python source as a normal text file...??   I checked the
jasper.log and the servlet.log, no error messages at all during startup or
when I was trying to execute this .py file.

I've had this working with previous versions (3.0) and future versions
(4.01b1) but can't seem to make it work with this version.

Has anyone else experience similiar problems with servlet mappings and
gotten this to work?

Thanks,
Chris


-- 
 __________________________________________________
/\				   	           \
\_| Christopher D. Gokey, SSAI, NASA/GCMD          |
  | 18 Martin Road, Shelburne Falls, MA  01370     |
  | Phone: Voice (413) 625-8129 / FAX 208-248-9055 |
  | cgokey@gcmd.nasa.gov / http://gcmd.nasa.gov    |
  | ICQ #52132386, AOL IM: chrisgokey              |
  |   _____________________________________________|_
   \_/______________________________________________/



Mime
View raw message