tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Gokey <cgo...@gcmd.gsfc.nasa.gov>
Subject mod_webapp.so: invalid ELF header
Date Wed, 05 Sep 2001 00:03:16 GMT
I've downloaded and installed the binary for Tomcat 4.0-b7.  I'm now
trying to install the mod_webapp connector for apache. I've been able to
cvs checkout the latest jakarta-tomcat-connectors/webapps and the apr and
build it.  When I copy the
apache-1.3/mod_webapp.so file into my
apache/libexec directory and try to start apache, I get this error:

[root@cgokey bin]# ./apachectl start
Syntax error on line 993 of /usr/local/apache_1.3.17/conf/httpd.conf:
Cannot load /usr/local/apache_1.3.17/libexec/mod_webapp.so into server:
/usr/local/apache_1.3.17/libexec/mod_webapp.so: invalid ELF header
./apachectl start: httpd could not be started

If I do a "file" on mod_webapp.so, I get this:
[cgokey@cgokey apache-1.3]$ file  mod_webapp.so
mod_webapp.so: Bourne shell script text

Any idea why this module is not building properly?

Chris

-- 
 __________________________________________________
/\				   	           \
\_| Christopher D. Gokey, SSAI, NASA/GCMD          |
  | 18 Martin Road, Shelburne Falls, MA  01370     |
  | Phone: Voice (413) 625-8129 / FAX 208-248-9055 |
  | cgokey@gcmd.nasa.gov / http://gcmd.nasa.gov    |
  | ICQ #52132386, AOL IM: chrisgokey              |
  |   _____________________________________________|_
   \_/______________________________________________/



Mime
View raw message