tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Ferne" <pe...@e-people.com>
Subject Tomcat 4.0 Final claims '/WEB-INF/web.xml not found' for /examples
Date Fri, 28 Sep 2001 10:55:53 GMT
Hi

I have an application which runs fine on Tomcat 3.2.3 and I am trying to run
it on Tomcat 4.0 Final.  I have successfully installed a binary distrib on
my W2K machine.  I can see the default index.html and I can run
/manager/list etc.  My epv.war file has been unpacked by Tomcat as I would
expect and the /manager application claims that my app and all the default
contexts are running, lets me restart them etc.  However when I try and
invoke the application via http://localhost/epv or ...epv/ I get '404
resource (/) is unavailable'.

Even stranger I get the same thing for the /examples context, which
complains about (/) and (/jsp) being unavailable.  Looking through the
examples log file I see:

----------------------------------------
2001-09-28 08:45:25 WebappLoader[/examples]: Deploying class repositories to
work directory C:\Program Files\Apache
Group\jakarta-tomcat-4.0\work\localhost\examples
2001-09-28 08:45:25 WebappLoader[/examples]: Reloading checks are enabled
for this Context
2001-09-28 08:45:25 StandardManager[/examples]: Seeding random number
generator class java.security.SecureRandom
2001-09-28 08:45:25 StandardManager[/examples]: Seeding of random number
generator has been completed
2001-09-28 08:45:25 ContextConfig[/examples]: Missing application web.xml,
using defaults only
2001-09-28 08:45:25 StandardWrapper[/examples:default]: Loading container
servlet default
2001-09-28 08:45:25 default: init
2001-09-28 08:45:25 StandardWrapper[/examples:invoker]: Loading container
servlet invoker
2001-09-28 08:45:25 invoker: init
2001-09-28 08:45:25 StandardWrapper[/examples:jsp]: Using Jasper classloader
for servlet jsp
2001-09-28 08:45:25 jsp: init
2001-09-28 08:45:25 Internal Error: File /WEB-INF/web.xml not found
----------------------------------------

...and yet %CATALINA_HOME%\webapps\examples\WEB-INF\web.xml clearly does
exist, I checked (it's the default).

It seems like it must be a general configuration issue of some kind and not
anything specific to my app.  The strange this is that it is all completely
vanilla (apart from the fact that I changed the port from 8080 to 80 in
server.xml), I just downloaded and installed the binary, dropped my epv.war
file in and restarted.

I've tried searching the mailing list archives to no avail, and I've already
stripped everything out from my jre/lib/ext directory in case of conflicts.
But no luck.

Any ideas or pointers would be greatly appreciated.  Not surprisingly this
is all on a very tight schedule. :-)

TIA
--
Peter Ferne, VP of Engineering, E-people Ventures Limited
tel +44 (0)870 733 0456  fax +44 (0)870 733 0457
mob +44 (0)701 0701 427  web www.e-people.com

e-people...deliver digital business


Mime
View raw message