tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ml...@roinet.com
Subject Re: pulling my hair out re: EJB in tomcat
Date Fri, 28 Sep 2001 13:39:27 GMT

Thanks again, Remy.  Still no luck, thought (same message).  Any idea how
"upcoming" 4.01 is?  :-)

Has anyone else had success making Tomcat 4.0 talk to JBoss 2.4.1 on
*different* machines?

- Marty



                                                                                         
                             
                    "Remy                                                                
                             
                    Maucherat"           To:     <tomcat-user@jakarta.apache.org>  
                                   
                    <rmaucher1@ho        cc:                                          
                                
                    me.com>              Subject:     Re: pulling my hair out re: EJB in
tomcat                        
                                                                                         
                             
                    09/27/2001                                                           
                             
                    05:29 PM                                                             
                             
                    Please                                                               
                             
                    respond to                                                           
                             
                    tomcat-user                                                          
                             
                                                                                         
                             
                                                                                         
                             




> >>      I've searched the archives to no avail.  I'm running Tomcat 4.0 /
> >> Apache on RH7.1, with JBoss 2.4.1 on another machine.
> >>
> >>      I'm able to run the standalone demo app from the RH7.1 box with
no
> >> problems whatsoever.  I have a jndi.properties file in my classpath.
> >>
> >>      When I run Tomcat with the same classpath, I get "Name not
defined
> in
> >> this context."
> >
> >Use the -nonaming option to launch Catalina. That will disable the JNDI
> ENC
> >support (and use the one from jBoss instead).
>
> Thanks for the tip.  I found a little more info at
> http://jakarta.apache.org/turbine/howto/jboss-howto.html
> The example on that page is exactly what I'm trying to accomplish for the
> moment, but I'm still experiencing problems.  I'm sniffing the network
> between the computers, and the Tomcat box is definitely communicating
with
> the JBoss box (i.e., no more naming issues!).  Now, however, I get:
>
> java.lang.ClassCastException: javax.naming.NameClassPair
>
> Like I said, what I'm trying to accomplish is exactly what the example at
> the above URL illustrates.  Any more ideas?

There's a class loading delegation bug in 4.0 (fixed for the upcoming
4.0.1)
which may cause this.

You can probably fix it by removing anything named jndi.jar in the Tomcat
distribution.

Remy






Mime
View raw message