tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Grishchenko" <vlad...@hotmail.com>
Subject Re: Jars in WEB-INF/lib and RMI stubs in WEB-INF/classes not found
Date Thu, 20 Sep 2001 22:54:51 GMT
Sounds like a beaten to death topic. Search TC archives for class loading.

--V.

PS: sorry for not being too helpful, but this question has been answered way
too many times.

----- Original Message -----
From: "Joshua van Tonder" <joshvt@intelligent-results.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Thursday, September 20, 2001 2:47 PM
Subject: Jars in WEB-INF/lib and RMI stubs in WEB-INF/classes not found


> How does classloading work in tomcat 3.2.2?
>
> In deploying my application I am having problems getting classes loaded
> aren't on the system classpath. I changed the tomcat.bat so that the
> generated classpath doesn't doesn't include the system classpath and only
> includes things built by the batch file.
>
> I have placed log4j.jar and crimson.jar into WEB-INF/lib for my app.
>
> For other reasons crimson.jar needs to be 1st on the classpath
(specifically
> b4 parser.jar) and I so try adding it by doing like so in batch file:
>
> set CP=%TOMCAT_HOME%\webapps\MYAPP\WEB-INF\lib\crimson.jar;%CP%
>
> But it isn't found. If I instead do: CP=%TOMCAT_HOME%\lib\crimson.jar it
> also isn't found.
>
> Only if I place it outside of %TOMCAT_HOME% and reference it are classes
> found.
>
> The wierd thing is that I can place log4j.jar in the %TOMCAT_HOME% and
have
> things work (but also can't find classes from it if it's added to
classpath
> referenced from WEB-INF/lib).
>
> This also extends to rmi stubs in the WEB-INF/classes directory. Other
> classes from our app in this dir our found except for the stubs.
>
> any ideas, I'm stu[bb|mp]ed...
>
>

Mime
View raw message