tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Maré <l...@webtothemax.com>
Subject Apache 1.3.20 & mod_webapp & Tomcat 4b7 HANGS on Windows
Date Fri, 07 Sep 2001 19:30:14 GMT
I'm having big problems getting this combination to work:
- Apache 1.3.20
- mod_webapp
- Tomcat 4b7
All were recently donwloaded and installed, using defaults as much as
possible.

Accessing the apache server and tomcat standalone is without problems.

In httpd.conf I added:
-----------------------
LoadModule webapp_module modules/mod_webapp.so
AddModule mod_webapp.c

WebAppConnection conn      warp  localhost:8008
WebAppDeploy     examples  conn  /examples/
WebAppInfo /webapp-info
-----------------------------

When accessing http://localhost/examples/ and clicking JSP, I'm seeing the
first 4 lines of the page, but then Tomcat hangs.

I get this error on the console:
--------------------------------
Starting service Tomcat-Standalone
Apache Tomcat/4.0-b7
Starting service Tomcat-Apache
Apache Tomcat/4.0-b7
java.lang.ArrayIndexOutOfBoundsException: No data available
        at
org.apache.catalina.connector.warp.WarpPacket.readUnsignedShort(WarpPacket.j
ava:183)
        at
org.apache.catalina.connector.warp.WarpPacket.readString(WarpPacket.java:218
)
        at
org.apache.catalina.connector.warp.WarpRequestHandler.handle(WarpRequestHand
ler.java:118)
        at
org.apache.catalina.connector.warp.WarpConnection.run(WarpConnection.java:19
4)
        at java.lang.Thread.run(Thread.java:484)
--------------------------------

There are NO errors in any of the Tomcat or Apache logs.

Any ideas?

Marcel Maré

WebToTheMax




Mime
View raw message