tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pier Fumagalli <>
Subject Re: Which version of should I use?
Date Wed, 05 Sep 2001 01:29:27 GMT
"Brian Santucci" <> wrote:

> I have a working environment of RedHat 6.2, Apache 1.3.12, and Tomcat 4.0
> beta 7 that is working with the that comes precompiled in the
> webapp-module-1.0-tc40b7-linux-glibc2.1.tar.gz file.  I have a web
> application with servlets and jsps that I can acess and they work fine.
> I am trying to get this same application to work in a RedHat 7.1, Apache
> 1.3.19, Tomcat 4.0 beta 7 environment.  My initial thought was to use the
> file from the glibc2.2 precompiled binary.  When I use this
> module, I get the following error:
> Loaded DSO modules/ uses plain Apach 1.3 API, this module might
> crash under EAPI! (please recompile it with -DEAPI)
> My next thought was to try the glibc2.1 precompiled binary.  I was able to
> start Apache without getting the error message, but when I went to access
> the web application I get a page not found error and my apache_log has the
> following error in it:
> Exception on socket
> Premature packet header end
> at
> org.apache.catalina.connector.warp.WarpConnection.recv(WarpConnection:236)
> ...(rest of stack trace omitted)
> My questions are:
> Given the environment I'm working in, which version of should
> I be using?  
> Should one of the precompiled binaries work for me?
> Do I need to compile my own and, if so, what options do I need to specify to
> deal with EAPI?  
> Is the IOException a bug, or is it a function of how I've configured my
> environment?
> Any help would be appreciated.

First of all, recompile mod_webapp for your environment... You're using a
glibc-2.1 version with glibc-2.2 ant that might create some problems... It's
all documented in the readme file...

Then, please send over some more information about WHY that packet header
end... Like log files from Apache and/or Catalina :)


View raw message