tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vaibhav Bakre" <vba...@cisco.com>
Subject Tomcat-Apache on Linux
Date Wed, 26 Sep 2001 08:14:23 GMT
Hi,

I am facing a problem when installing
apache-tomcat. If you have got the answer please mail it to me ASAP.

Problem Description:

I am trying to get Tomcat working with Apache and I'm having some
problems.
I'm using Redhat Linux 6.2, Apache 1.3.14, Tomcat 3.2.1

All I want to do is get the Servlets and JSPs in the
$TOMCAT_HOME/webapps/examples directory to work.

All my jsp's and servlets give 404 errors.

This is what I have in my tomcat.conf file:

 <IfModule mod_jserv.c>
  ApJServManual on
  ApJServDefaultProtocol ajpv12
  ApJServSecretKey DISABLED
  ApJServMountCopy on
  ApJServLogLevel notice
  ApJServDefaultPort 8007

  AddType text/jsp .jsp
  AddHandler jserv-servlet .jsp
  Alias /examples /usr/jakarta-tomcat/webapps/examples
  <Directory "/usr/jakarta-tomcat/webapps/examples">
   Options Indexes FollowSymLinks
  </Directory>
  <Location /examples/WEB-INF/ >
   AllowOverride None
   deny from all
  </Location>

  ApJServMount /examples/servlet /examples

 </IfModule>

The 404 responses are coming from Apache, not the Tomcat server.  They
also
show up in my apache error log.  It almost seems as though the
ApJServMount
command isn't even being executed.  Requests for servlets are not being
forwarded to Tomcat.

thanks,
Vaibhav


Mime
View raw message