tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zachmann, Jens" <jens.zachm...@sapmarkets.com>
Subject Tomcat on PDA?
Date Tue, 11 Sep 2001 08:41:18 GMT
Hi!

I tried to run the tomcat windows version on an iPAQ. The webserver is
running and the servlet engine works fine. But the JSP doesn't run. This is
the jasper.log file from tomcat:

2001-09-11 09:53:48 - Scratch dir for the JSP engine is:
/zCat/work/localhost_8080%2Fexamples
2001-09-11 09:53:48 - IMPORTANT: Do not modify the generated servlets

2001-09-11 09:57:52 - JspEngine --> /jsp/num/numguess.jsp
2001-09-11 09:57:52 -     ServletPath: /jsp/num/numguess.jsp
2001-09-11 09:57:52 -        PathInfo: null
2001-09-11 09:57:52 -        RealPath:
/zCat/webapps/examples/jsp/num/numguess.jsp
2001-09-11 09:57:52 -      RequestURI: /examples/jsp/num/numguess.jsp
2001-09-11 09:57:52 -     QueryString: null
2001-09-11 09:57:52 -  Request Params: 
2001-09-11 09:57:52 - Classpath according to the Servlet Engine is:
/zCat/webapps/examples/WEB-INF/classes

Perhaps the Problem is that a second service Tomcat wants to start on the PC
will not be started (without any error) on the PDA. The following line does
not appear on the PDA:

2001-09-11 09:11:52 - PoolTcpConnector: Starting Ajp12ConnectionHandler on
8007

And the error page looks like this:

Error: 500
Location: /examples/jsp/num/numguess.jsp
Internal servlet Error:
javax.servlet.ServletException: sun/tools/javac/Main
  at org.apache.jasper.servlet.JspServlet.service()
  at javax.servlet.http.HttpServlet.service()
  at org.apache.tomcat.core.ServletWrapper.doService()
  at org.apache.tomcat.core.Handler.service()
  at org.apache.tomcat.core.ServletWrapper.service()
  at org.apache.tomcat.core.ContextManager.internalService()
  at org.apache.tomcat.core.ContextManager.service()
  at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection()
  at org.apache.tomcat.service.TcpWorkerThread.runIt()
  at org.apache.tomcat.util.ThreadPool$ControlRunnable.run()
  at java.lang.Thread.run()
Root cause:
java.lang.NoClassDefFoundError: sun/tools/javac/Main
  at org.apache.jasper.compiler.Compiler.compile()
  at org.apache.jasper.servlet.JspServlet.doLoadJSP()
  at org.apache.jasper.servlet.JasperLoader12.loadJSP()
  at org.apache.jasper.servlet.JspServlet.loadJSP()
  at
org.apache.jasper.servlet.JspServlet$JspServletWrapper.loadIfNecessary()
  at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service()
  at org.apache.jasper.servlet.JspServlet.serviceJspFile()
  at org.apache.jasper.servlet.JspServlet.service()
  at javax.servlet.http.HttpServlet.service()
  at org.apache.tomcat.core.ServletWrapper.doService()
  at org.apache.tomcat.core.Handler.service()
  at org.apache.tomcat.core.ServletWrapper.service()
  at org.apache.tomcat.core.ContextManager.internalService()
  at org.apache.tomcat.core.ContextManager.service()
  at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection()
  at org.apache.tomcat.service.TcpWorkerThread.runIt()
  at org.apache.tomcat.util.ThreadPool$ControlRunnable.run()
  at java.lang.Thread.run()

Does anybody understand this internal problem an can explain it? Or where
can I look for the problem?

Many thanks,
Jens

Mime
View raw message