tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Rimov <rim...@centercomp.com>
Subject [TC4] WebApp Reloading And BouncyCastle Crypto Provider
Date Fri, 28 Sep 2001 07:03:27 GMT
Hello All,

I've got kind of an interesting problem using JCE stuff with TC4.  [I'm 
using JDK 1.3.0 & 1.3.1].  I'm using the bouncycastle cryptographic 
library.  The trouble is like so:

1 - Start Tomcat, run my application... no troubles.

2 - Reload the webapp through the manager application.  Things seem to load 
right.

3 - Invoke code like so:
	theCipher = Cipher.getInstance(
                 theCipherString,theProvider.getName());

theProvider = BouncyCastleProvider
theCipherString = I've tried:
		"Rijndael/OFB/PKCS5Padding"
			and
		"Twofish/CFB/PKCS5Padding"


I then get a ClassCastException() thrown deep within BouncyCastle saying 
that the algorithm is found but the $ signed classname is not the 
appropriate class type. [I've tried a few different ciphers]

I have no idea whether this is a classLoader problem within Tomcat that is 
causing this, or whether it's in BouncyCastle.  But since I know that at 
least Jon Eaves lurks around Apache, I figured this would reach the most 
people in the least amount of bandwidth :-).

Thanks in advance for any help on this!
					-Mike


Mime
View raw message