tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob W. van Swol" <vans...@nlr.nl>
Subject mod_webapp partly working
Date Wed, 26 Sep 2001 12:32:56 GMT
Hi,

I managed to get Tomcat 4.0 working together with mod_webapp on Linux
(RH6.2 kernel 2.4.10). However: http://localhost/webapp-info/ shows the
configuration indeed. http://localhost/examples/ shows the directory
structure of the examples dir. BUT if i go to
http://localhost/examples/servlets i get /examples/servlets/index.html
was not found on this server. http://localhost/cocoon/Cocoon.xml works
BUT again I cannot see the static pages. What did I forget to
congiure???


BTW.
Regarding Cocoon 1.8.2 installation. I had also the 'not a servlet
problem', the
solution is simple: just remove servlet.jar (or servlet-2.2.jar) from
the cococon/WEB-INF/lib directory. The next thing you'll find is that 
there is an error in the init procedure because the xsp processor cannot
find some resources.  Also here the solution is simple. Extract the .xsl
files that are requested (see your cocoon.properties) from the
cocoon.jar and place them somewhere you want and then change your
cocoon.properties and point to these files with an absolute path
(instead of the resource:// references.)

Rob

-- 
_____________________________________________________________

Rob W. van Swol
National Aerospace Laboratory NLR       Tel. +31 527 248252
P.O. Box 153                            Fax  +31 527 248210
8300 AD Emmeloord                       E-Mail vanswol@nlr.nl
The Netherlands                         http://www.neonet.nl/


Mime
View raw message