tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Daney <dda...@avtrex.com>
Subject Re: Tomcat 4.0 <Context/> Problem
Date Mon, 03 Sep 2001 20:52:26 GMT
Craig R. McClanahan wrote:

>
>On Thu, 30 Aug 2001, Calvin Lau wrote:
>
>>Date: Thu, 30 Aug 2001 21:32:53 -0700
>>From: Calvin Lau <alienx@uclink4.berkeley.edu>
>>Reply-To: tomcat-user@jakarta.apache.org
>>To: tomcat-user@jakarta.apache.org
>>Subject: Tomcat 4.0 <Context/> Problem
>>
>>I'm trying to get Tomcat4.0 to recognize an application in
>>C:/web/blitzDev rather than in the webapps directory.  For
>>some reason it worked fine in Tomcat 3.2 but not Tomcat4.0.
>>
>>When I add:
>>
>><Context path="/"
>> docBase="c:/web/blitzDev"
>> crossContext="false"
>> debug="0"
>> reloadable="true" >
>></Context>
>>
>>I get the following when I start Tomcat:
>>
>>   Starting service Tomcat-Standalone
>>   Apache Tomcat/4.0-b7
>>   PARSE error at line 7 column -1
>>   org.xml.sax.SAXParseException: XML declaration may
>>   only begin entities.
>>   Starting service Tomcat-Apache
>>   Apache Tomcat/4.0-b7
>>
>>Anyone know what I should do?
>>
>
>Sounds like some sort of XML syntax error around line 7.  Note that it is
>*not* necessarily server.xml that is the problem -- check your web.xml
>file as well.
>
>>Calvin
>>
>>
>Craig
>
>
I think I had a similar problem.

I found that if the 'servlet-name' of a servlet is 'default' then there 
are XML parsing errors.  Changing the servlet name allowed me to run the 
same web-app in both 3.2 and 4.0b7.

This may not be your problem, but I thought I would chime in anyhow.

David.




Mime
View raw message