tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: mod_webapp and make !!!
Date Mon, 03 Sep 2001 07:50:16 GMT
Pier Fumagalli wrote:
> 
> "hatim" <hatnet@free.fr> wrote:
> 
> > Hi
> >
> > i have redhat 6.2 with kernel 2.2.18 ( Va linux) , apache 1.3.20
> > i tried to use the mod-webapp.so comming from
> > webapp-module-1.0-tc40b7-linux.tar.gz
> > but apache didnt start because of error
> > Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
> > /lib/libc.so.6: version `GLIBC_2.2' not found (required by
> > /usr/local/apache/libexec/mod_webapp.so , my glibc is
> > glibc-2.1.3-22.1
> > glibc-devel-2.1.3-22.1
> > and for resean dependances i can't upgrade to glibc-2.2....
> 
> There is a GLIBC-2.1 version available for download too...
> 
> > then i tried ( today) to install the source of webapp to compile it , from
> > CVS , i read the README.TXT , and i follow exactelly the explication :
> > i can configure , but when  i type make i have this error
> > Compiling sources in /app/webapp-module-1.0-tc40b7/apache-1.3...
> > make[1]: Entering directory `/app/webapp-module-1.0-tc40b7/apache-1.3'
> > Linking Apache 1.3 WebApp Module
> > /app/webapp-module-1.0-tc40b7/apr/libtool: mod_webapp.lo: command not found
> > make[1]: *** [mod_webapp.so] Error 127
> > make[1]: Leaving directory `/app/webapp-module-1.0-tc40b7/apache-1.3'
> > make: *** [local-all] Error 2
> >
> > any idea ? any help ?
> 
> Ah, yes.. Your APXS is screwed. For some reason (that I don't understand)
> some systems don't come with a correctly configured APXS.
> If you try to do:
>    apxs -q CC
> and
>    apxs -q LD_SHLIB
> you won't see any output, while on my system they come out correctly as "cc"
> and "ld"...

Would it make sense to test this in configure and use ld/cc when apxs is broken?

> 
>     Pier

Mime
View raw message