tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pete <p...@claudia.dyn.dhs.org>
Subject Re: Segmentation Fault when modifying classpath?!
Date Sun, 02 Sep 2001 07:25:39 GMT
You're not by any chance using Suns JDK 1.3.1 and Linux are you?


If you are, add 'ulimit -s 2048' to tomcat.sh (or just type it in the 
shell you launch tomcat from).

This limits the maximum stack size, but i can't give you more detail 
than that, all i know is it works for me.

This problem only seems to show up with xerces, but since it works fine 
on other JVMs, and on Sun JDK1.3.1 on Windows, i'd say Sun have a buggy 
JVM here.

IBM's JDK does not have this problem, so that may be another option for you.

Hope that helps

-Pete

>Ok...
>
>All this surrounds modifying tomcat.sh per install instructions found in
>apache-soap.
>
>Per Apache-Soap's "Getting Tomcat Ready", I have changed my classpath to put
>xerces.jar at the beginning of my classpath as follows:
>....
>unset CLASSPATH
>
>CLASSPATH=/usr/local/java/lib/xerces.jar
>
>for i in ${TOMCAT_HOME}/lib/* ; do
>  if [ "$CLASSPATH" != "" ]; then
>    CLASSPATH=${CLASSPATH}:$i
>  else
>    CLASSPATH=$i
>  fi
>done
>...
>
>When starting tomcat I get the following:
>
>Using classpath:
>/usr/local/java/lib/xerces.jar:
>/opt/jakarta-tomcat-3.2.3/lib/activation.jar:
>/opt/jakarta-tomcat-3.2.3/lib/ant.jar:
>/opt/jakarta-tomcat-3.2.3/lib/jasper.jar:
>/opt/jakarta-tomcat-3.2.3/lib/LICENSE:
>/opt/jakarta-tomcat-3.2.3/lib/mail.jar:
>/opt/jakarta-tomcat-3.2.3/lib/servlet.jar:
>/opt/jakarta-tomcat-3.2.3/lib/soap.jar:
>/opt/jakarta-tomcat-3.2.3/lib/test:
>/opt/jakarta-tomcat-3.2.3/lib/webserver.jar:
>/opt/jakarta-tomcat-3.2.3/lib/xerces.jar:
>/usr/local/java/jdk1.3.1/lib/tools.jar
>
>/opt/jakarta-tomcat-3.2.3/bin/tomcat.sh: line 181: 12681 Segmentation fault
>$JAVACMD $TOMCAT_OPTS -Dtomcat.home=${TOMCAT_HOME}
>org.apache.tomcat.startup.Tomcat "$@"
>
>I can not figure out for the life of me why this is happening.  I've also
>tried setting the classpath from the shell with the exact same results.  Any
>hints appreciated.
>
>Thanks,
>
>Al Calbazana
>




Mime
View raw message