tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Stranathan <w...@thestranathans.com>
Subject Re: [TC3.3b1] use of taglib causes "org.apache.crimson.jaxp.DocumentBuilderFactoryImpl not found error"
Date Sat, 01 Sep 2001 11:53:43 GMT
Take the XML related jars in TOMCAT_HOME/lib and rename them to 
x[whatever].jar (for example, xjaxp.jar).  Then put Velocity's XML 
parsers in TOMCAT_HOME/lib.

I know it's a kludge, but AFAICT, these sorts of classloader issues have 
been corrected in 4.0.  (Which is all the Struts people can't understand 
why their stuff suddenly DOESN'T work - all the Struts WAR's come 
without any parser libraries.)

w

Paul Spencer wrote:

> I am getting the following error while using Jetspeed with Tomcat
> 3.3-b1.  This error does NOT occur in Tomcat 3.3-m4!
>   [Fri Aug 31 22:19:33 EDT 2001] -- ERROR -- Error rendering Velocity
> template:   /controllers/html/multicolumn.vm: Invocation of method
> 'getContent' in  class
> org.apache.jetspeed.portal.controls.VelocityPortletControl threw
> exception class  javax.xml.parsers.FactoryConfigurationError :
> Provider   org.apache.crimson.jaxp.DocumentBuilderFactoryImpl not found
> 
> In addition the .java file created in the work directory is has a size
> of 0 bytes.
> 
> I copied crimson.jar and jaxp.jar to the lib/apps directory, as
> suggested in
> http://www.mail-archive.com/tomcat-dev@jakarta.apache.org/msg13224.html
> ,
> but that did not work.
> 
> My jsp file is below (Note this file work in Tomcat v3.3-m3 and -m4):
>   <%@ taglib uri='/WEB-INF/templates/jsp/tld/template.tld'
> prefix='jetspeed' %>
>   <p>
>     <b>JSP</b> Hello World!
>     <b>Server date:</b> <jetspeed:info requestedInfo="ServerDate" />
>   </p>
> 
> 
> Ideas?
> 
> Thank you
> Paul Spencer
> 



Mime
View raw message