tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Sutherland (UKI)" <...@ukinternet.co.uk>
Subject RE: CPU goes to 100%
Date Wed, 05 Sep 2001 15:21:14 GMT
Hi Anand,

Just a suggestion.... check to see that you are clearing memory (=nothing)
after instantiating objects, otherwise 2000/NT keeps hold of it and only
releases it it after a refualt period (say 30 mins...) - and this can build
quite quickly after each user leaves the app. I dont know that much yet
about the JSP environment, just learning, but this is common problem on
similar developments with VB DLL's when they have not been written properly
(where the object has been used in the page and not set it to 'nothing' when
you present the page to the user...)

Hope this is a help.

Rgds

Joe Sutherland

-----Original Message-----
From: Murthy, Anand [mailto:Anand.Murthy@tfn.com]
Sent: 05 September 2001 15:13
To: 'tomcat-user@jakarta.apache.org'
Subject: CPU goes to 100%


Hi,

We have a big application using Tomcat v3.2.1 and we are doing alot of
Database connections.  It is running on Windows 2000 server and we are using
Sun's Java 1.3.  Most of the day the CPU stays at 0%, but for some reason
every afternoon it goes to 100% and application slows down to a crawl.  At
the end of each jsp file, we do some garbage collection, but it still does
not seem to help.

Does anyone have any ideas?

Thank you,

Anand Murthy
Jr. Software Engineer
Thomson Financial Research
617-856-1795

Mime
View raw message