tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tomcat-user" <tomcat-u...@iq-computing.de>
Subject Getting "web-application not yet deployed" errors frequently
Date Fri, 21 Sep 2001 11:25:37 GMT

Hi, I seem to have a problem with Tomcat 4.

I placed a simple test.jsp into webapps/ROOT, and it compiled and worked correctly. However,
when I opened http://mysite/tomcat-docs and switched back to the test.jsp, it didn't appear.
Instead, I got a 404 error stating that the "web-application [was] not yet deployed". When
going back to http://mysite/tomcat-docs to check things out, I got the same error again. Reloading
the page didn't help either.

I searched this mailing list's archive if someone had the same problem, but I couldn't find
anything related. So I tried to go to http://mysite/tomcat-docs again, and surprisingly it
worked okay again, although I didn't do anything on the machine or its configuration at all.
I also didn't restart Apache or Tomcat.

I'm using Apache 1.3.19 on SuSE Linux 7.2 with Tomcat 4.0 Final using a (standard) self-compiled
mod_webapp.so (--with-apxs). tomcat/logs/* or the Apache logs didn't mention anything regarding
that error as far as I could see.

Tomcat's server.xml config file is standard except for the stand-alone service, which I commented
out completely. I also commented out the "examples" context in the Apache service.
Apache's httpd.conf contains standard mod_webapp config entries as mentioned in Tomcat's server.xml,
except for WebAppDeploy, where I only made the "ROOT" context visible on /.

I think the 404 error stated that it happened in wa_server.c in line 137, but I don't remember
quite correctly.

Is there a way to find out why that error occurs and how to fix this?
Thanks in advance.

-- 
</Mickey>

Mime
View raw message