tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin HaleBoyes <kcbo...@yahoo.com>
Subject Re: Repost: taglib and rtexprvalue problem/bug
Date Tue, 11 Sep 2001 18:34:14 GMT
Thanks, I'll make sure I properly encode things from now on.

In the mean time, I removed any "special" characters and have
only alphabetic characters in my <jsp:param> list and I still
get:

   org.apache.jasper.compiler.ParseException:
      /WEB-INF/jsp/od.jsp(11,53) Attribute from has no value

So, I still see it as a problem with the use of an expression
as the attribute value in a custom taglib tag.

Kevin HaleBoyes


>From: "Craig R. McClanahan" 
>
>I just answered this in the bug report, but will answer here as well
>since
>it's been raised here.
>
>Request URIs (including the query string) processed by servlet
>containers
>must conform to the requirements of HTTP.  In this case, the
>relevant spec
>is RFC 2396, Section 3.2, which describes the legal syntax for query
>strings.  In particular, characters like ':' and '=' are *reserved*,
>and
>must be URL encoded in order to be processed.
>
>This same requirement, therefore, applies to query parameters
>included
>with <jsp:include> and RequestDispatcher.include().
>
>Craig McClanahan




____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie

Mime
View raw message