tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <craig...@apache.org>
Subject Re: Possible problem with HttpServletResponse.encodeURL behavior in Catalina
Date Sun, 02 Sep 2001 04:51:55 GMT
The only way to debug such a problem is to see the *actual* stack trace
you are encountering.  Can you post it?

Craig McClanahan


On Tue, 28 Aug 2001 mik@galaxie.net wrote:

> Date: Tue, 28 Aug 2001 14:15:13 +0200
> From: mik@galaxie.net
> Reply-To: tomcat-user@jakarta.apache.org
> To: tomcat-user@jakarta.apache.org
> Subject: Possible problem with HttpServletResponse.encodeURL behavior in
>     Catalina
>
> Hello,
>
> We have been experiencing a strange behavior of Catalina's implementation
> of HttpServletResponse.encodeURL()
>
> Application calls to this method (from a servlet running in Catalina)
> sometimes cause a NullPointerException.
>
> This occurred apparently at random, especially in situations where
> multiple calls to this methods were made in a short timespan.
>
> Tracing the exception showed that the reference to the the exception
> was caused by the implementing class in Catalina loosing the reference
> to the HttpServletResponse object.
>
> We experienced this problem with tomcat 4.0-b1, 4.0-b5 and 4.0-b7
> (which are all versions we worked with).
>
> We would appreciate any help on this issue.
>
> Many thanks
>
> 				Mikhael Janson
> 				MyComponents.com
>
>
>


Mime
View raw message