tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "PREETHY MANOHAR" <preethymano...@hotmail.com>
Subject RE: My JSP pages are freezing !!
Date Thu, 01 Jan 1970 00:00:00 GMT
Hi Christian,

try this code in the jsp
<%
  response.setHeader("Cache-Control","no-cache");
  response.setHeader("Pragma","no-cache");
  response.setDateHeader ("Expires", 0);
%>

Preethy

>From: "James, Stuart" <stuart.james@cazenove.com>
>Reply-To: tomcat-user@jakarta.apache.org
>To: "'tomcat-user@jakarta.apache.org'" <tomcat-user@jakarta.apache.org>
>Subject: RE: My JSP pages are freezing !!
>Date: Wed, 15 Aug 2001 14:06:21 +0100
>
>is it possible your browser is caching the result? if so add the following
>to the footer of the page,
>
>
><HEAD>
>     <meta http-equiv="pragma" content="no-cache">
>     <meta http-equiv="cache-control" content="no-store">    <!-- HTTP 1.1
>-->
>     <metta HTTP-EQUIV="Expires" CONTENT="Tue, 04 Dec 1993 21:29:02 GMT">
>     <meta HTTP-EQUIV="PRAGMA" CONTENT="NO-CACHE">
></HEAD>
>
>or put a system.out.println inside the jsp page to display when its being
>called and finished running
>
>-----Original Message-----
>From: Rob S. [mailto:rslifka@sfu.ca]
>Sent: Wednesday, August 15, 2001 1:58 PM
>To: tomcat-user@jakarta.apache.org
>Subject: Re: My JSP pages are freezing !!
>
>
>Hi Christian,
>
>Not to be skeptical, but it doesn't *sound* like a Tomcat problem.  As 
>well,
>the page isn't "freezing" per se, which would imply some sort of time-out,
>it's just looking the same when you hit it again.  You'll need to provide
>more detail about the page if you want help, but I'm reluctant to solve 
>your
>JSP programming problems <grumble>.
>
>- r
>
>On Wed, 15 Aug 2001 08:51:41 -0300 tomcat-user@jakarta.apache.org wrote:
> >     Hello all ! I have tomcat 3.3  with apache and it seems work fine
> > until now. I have a JSP page that receive
> >     only one param , execute a query in a database (interbase) , and
> > make the output.
> >     All work fine during some time but suddenly, when i execute the page
> >
> > with different values for the param, the output
> > is always the same , i.e., the output always show the answer not matter
> > what value i put for the param.
> >     It seems like the page freezing with an old value .
> >
> >    Christian
>
>
>
>
>___________________________________________________
>Email Disclaimer
>
>This communication is for the attention of the
>named recipient only and should not be passed
>on to any other person. Information relating to
>any company or security, is for information
>purposes only and should not be interpreted as
>a solicitation or offer to buy or sell any security.
>The information on which this communication is based
>has been obtained from sources we believe to be reliable,
>but we do not guarantee its accuracy or completeness.
>All expressions of opinion are subject to change
>without notice.  All e-mail messages, and associated attachments,
>are subject to interception and monitoring for lawful business purposes.
>___________________________________________________


_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp


Mime
View raw message