tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GOMEZ Henri <>
Subject RE: link tomcat <-> apache
Date Thu, 23 Aug 2001 16:21:40 GMT
mod_webapp is ONLY for Tomcat 4.0.

For 3.2 and 3.3 (or 4.0), use mod_jk instead

# httpd.conf

AddModule mod_jk.c

JkWorkersFile /etc/httpd/conf/
JkLogFile 	  /var/log/httpd/mod_jk.log
JkLogLevel 	  debug

Alias /examples "/var/tomcat/webapps/examples"
<Directory "/var/tomcat/webapps/examples">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all

JkMount /examples/servlet/* ajp13
JkMount /examples/*.jsp ajp13

<Location "/examples/WEB-INF/">
    AllowOverride None
    deny from all

Alias /admin "/var/tomcat/webapps/admin"
<Directory "/var/tomcat/webapps/admin">
    Options FollowSymLinks

JkMount /admin/servlet/* ajp13
JkMount /admin/*.jsp ajp13

<Location "/admin/WEB-INF/">
    AllowOverride None
    deny from all




Henri Gomez                 ___[_]____
EMAIL :        (. .)                     
PGP KEY : 697ECEDD    ...oOOo..(_)..oOOo...
PGP Fingerprint : 9DF8 1EA8 ED53 2F39 DC9B 904A 364F 80E6 

>-----Original Message-----
>From: zze-DELARUE Franck stagiaire FTRD/DMI/LAN
>Sent: Thursday, August 23, 2001 6:07 PM
>To: ''
>Subject: link tomcat <-> apache
>hi everyone,
>i've installed tomcat 3.2.2 on linux with apache. I try to 
>make a connection
>between apache and tomcat but it doesn't work at all. I've copied the
>modules mod_jserv, mod_jk, mod_webapp in the right directory 
>and changed the
>http.conf file to use these modules like this :
>    LoadModule webapp_module libexec/
>    AddModule mod_webapp.c
>    Include conf/mod_jk.conf
>    Include conf/tomcat-apache.conf
>There is maybe something else to do or to add to the httpd.conf like : 
>    WebAppConnection conn warp localhost:8007
>    WebAppDeploy examples conn  /examples
>    WebAppInfo /webapp-info
>but this does not work ...
>Thanks in advance.

View raw message