tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paresh Deshpande <pare...@india.triviumsys.com>
Subject RE: problem in loading jar files in WEB-INF\lib directory
Date Fri, 17 Aug 2001 14:18:55 GMT
hey rob, 
my servlet calls a class which tries to instantiate JNDI's InitialContext 
by passing env Hashtable...
....
env.put(Context.INITIAL_CONTEXT_FACTORY,
"com.sun.jndi.fscontext.RefFSContextFactory");
....
initialContext = new InitialContext(env);

the class com.sun.jndi.fscontext.RefFSContextFactory is available in the jar
file in my
WEB-INF\lib folder. And the error that I get while loading the servlet is
....

getInitialContext:exception: javax.naming.NoInitialContextException: Cannot
instantiate class: com.sun.jndi.fscontext.RefFSContextFactory [Root
exception is java.lang.ClassNotFoundException:
com.sun.jndi.fscontext.RefFSContextFactory]
getInitialContext:More Details: Cannot instantiate class:
com.sun.jndi.fscontext.RefFSContextFactory

You really are onto helping me, aren't you? if you could solve this one, I
owe you a mug of
beer, when you come donw to Bangalore...
paresh

-----Original Message-----
From: Rob S. [mailto:rslifka@sfu.ca]
Sent: Friday, August 17, 2001 7:34 PM
To: tomcat-user@jakarta.apache.org
Subject: Re: problem in loading jar files in WEB-INF\lib directory


> Then, the only question remaining is classes in my jar file are not being
> loaded for
> some reason. While loading the servlet, somewhere midway, the classes in
> WEB-INF\lib
> directory are not being loaded. strange isn't it?

How do you know the classes are not being loaded?  What kind of error
message are you getting?

"Help me help you" =)

- r



Mime
View raw message