tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Navarro, Jose" <Jose.Nava...@ideg.es>
Subject Can anyone send me mod_jk.so for Redhat 7.0 / Apache 1.3.14? / To mcat 3.2.1
Date Wed, 01 Aug 2001 08:46:07 GMT
Hi,

I've been trying to install Tomcat 3.2.1 in a Redhat 7.0 box running Apache
1.3.14 for a few days.

As many people report in many cases, Tomcat works nice standalone (as well
as Apache) but cannot integrate them to work together. Well, this is not
exactly true; the apache's logs say that "apache / mod_jk" has been started.
That is, it seems that apache realizes that mod_jk is working...

The actual problem is that while Tomcat serves both .jsps and servlets when
using URLS of the sort http://myserver:8080..., apache seems not to be
redirecting these requirements when I try to execute them through apache
itself. The browser simply stalls... forever.

I've read the howtos and even the archives and followed all the directions
given by the people contributing to this list but one: I have not compiled
mod_jk.so by myself.

I tried to do it one hour ago, but, I do not know why, apxs does not exist!
I tried to find this program with no success at all. In fact, I'm not the
one who set up the box, so don't know how Apache was built. Still worse, I'm
not a linux expert, I'm not able to reinstall it.

Well, since I downloaded my current version of mod_jk.so from the web (it
was jakarta's) some time ago, I'm not sure whether it is the right one.
Since it seems that everything else I did is correct, I *guess* that the
problem is mod_jk.so itself. That's why I ask you to send me the "right"
version (my email address is jose.navarro@ideg.es).

By the way, mod_jk.log is created and always empty. jasper.log and
servlets.log have the usual lines on them. I can see ports 8007 and 8009
both listening. I have included NO additional contexts (I'm just trying to
run the examples). I have defined the right TOMCAT_HOME and JAVA_HOME paths
in workers.properties (as well as the ps as /). I have created an ajp13
connector in server.xml following the directions given in one of the
messages in the archive.I have copied mod_jk.conf-auto in the same directory
than httpd.conf and appended the line "include
/the/full/path/to/mod_jk.conf-auto"
at its end. When booting, I stop apache, start tomcat, and restart apache
(in this precise order). And see no errors at all in the log files.

My jdk is 1.3.0_02 (sun's).

And I'm desperate.

Can you help me?

Thanks alot for your interest!

Jose.

Mime
View raw message