tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob S." <rsli...@sfu.ca>
Subject Re: Problem with loading servlets on start up
Date Thu, 01 Jan 1970 00:00:00 GMT
http://localhost:8080/hellouser/hellouser.jsp

is how you would request your servlet.  I have NO idea how Tomcat deals with servlets named
like JSP files.  A servlet spec guru might be required to answer that one =)  Err, just found
it, section 10.

You're better off naming it something like "HelloUserServlet" or just "HelloUser".

- r

On Mon, 20 Aug 2001 16:17:30 +0300 tomcat-user@jakarta.apache.org wrote:
> Hello,
> I'm a quiet newbie with Tomcat, and I have problems with running correctly
> the sample "HelloUser" under Tomcat v3.2.1
> I have cleaned the directory "webapps" and put there only the folder
> "hellouser" with "web-inf" and "meta-inf" subfolders, the subfolder
> "web-inf" looks like this :
> ...WEB-INF\classes\hello\NameHandler.class
> I made a web.xml-file looking like this:
> 
> <web-app>
>     <servlet>
> 	<servlet-name>
> 	   hellouser.jsp</servlet-name>
> 	<servlet-class>
> 	   hello.NameHandler</servlet-class>
> 	<load-on-startup>
> 	    10</load-on-startup>
>     </servlet>
> </web-app>
> and it doesn't work - the .class file is not loading on start up.
> Please tell me where is my mistake.
> Many thanks in advance
> Atanas
> 
> 
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp




Mime
View raw message