tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "A.L." <amoslie...@yahoo.com>
Subject RE: Servlet Runs SLow
Date Wed, 15 Aug 2001 16:05:03 GMT

I don't see how it could be the form submission if it
runs fine in explorer.  
Plus I can see Tomcat receive the request immediately
after I submit the form. 

I will meanwhile try to register a start and end time.

-amos




--- Martin van den Bemt <martin@isallineed.org> wrote:
> so the form submission is probably the problem..
> call a method which
> registers start and endtime, maby that will clear up
> where the problem is..
> 
> Mvgr,
> Martin
> 
> > -----Original Message-----
> > From: A.L. [mailto:amoslieber@yahoo.com]
> > Sent: Wednesday, August 15, 2001 5:52 PM
> > To: tomcat-user@jakarta.apache.org
> > Subject: Re: Servlet Runs SLow
> >
> >
> > The first time I load the page in Netscape
> everything
> > seems fine,  it loads almost instantaneously.
> > However, when I submit the query to change the
> month
> > calendar, netscape takes a while to reload the
> page
> > and show the new calendar.  I can see that TOmcat
> > receives the request immediately, and I assume
> that
> > since Netscape appears to be loading it receives
> the
> > response immediatley.
> >
> > Thanks,
> >   -Amos
> >
> >
> > --- Jim Seach <jwseach@yahoo.com> wrote:
> > > I copied the html into a static file and was
> able to
> > > bring it up
> > > immediately in Netscape 4.76, so it doesn't
> appear
> > > to be the contents
> > > of the form that is the problem.
> > >
> > > Does it take a long time to display, or does it
> just
> > > not appear to
> > > finish loading?  I have also noticed that
> sometimes
> > > even after the page
> > > has loaded, Netscape still appears to be
> working.
> > > So far, I have just
> > > ignored it.
> > >
> > > Jim
> > >
> > > --- "A.L." <amoslieber@yahoo.com> wrote:
> > > > Below is the code that is returned:
> > > >
> > > > It seems that Netscape might have problems
> with
> > > the
> > > > FORM data.  It does seem as if the server is
> > > sending
> > > > the reponse immediately.  Or maybe it is
> having
> > > > trouble with the javascript functions... Any
> > > > suggestions
> > > >
> > > > (I am only running TOmcat by the way)
> > > >
> > > >
> > > >
> > > > <html>
> > > > <head>
> > > > <title>Calendar</title>
> > > > </head>
> > > > <BODY BGCOLOR="#FDF5E6">
> > > > <FORM METHOD=POST ACTION="/jd/Calendar">
> > > > <SELECT NAME="dates" MULTIPLE>
> > > > <OPTION VALUE="Jan"> January </OPTION>
> > > > <OPTION VALUE="Feb"> February</OPTION>
> > > > <OPTION VALUE="Mar"> March</OPTION>
> > > > <OPTION VALUE="Apr"> April</OPTION>
> > > > <OPTION VALUE="May"> May</OPTION>
> > > > <OPTION VALUE="June"> June</OPTION>
> > > > </SELECT>
> > > > <INPUT TYPE=SUBMIT>
> > > > </FORM>
> > > > March2001<form METHOD=GET
> > > > NAME="date2"ACTION="/jd/Calendar"><input
> > > type=hidden
> > > > NAME="d"><script
> language="JavaScript">function
> > > > choose(n){document.date2.d.value =
> > > >
> > >
> >
>
n;document.date2.submit();}</script><table><tr><td></td><td></td><
> > td></td><td></td><td><a
> > > > href="javascript:choose(1)">1</a></td><td><a
> > > > href="javascript:choose(2)">2</a></td><td><a
> > > >
> > >
> >
>
href="javascript:choose(3)">3</a></td></tr><tr><td><a
> > > > href="javascript:choose(4)">4</a></td><td><a
> > > > href="javascript:choose(5)">5</a></td><td><a
> > > > href="javascript:choose(6)">6</a></td><td><a
> > > > href="javascript:choose(7)">7</a></td><td><a
> > > > href="javascript:choose(8)">8</a></td><td><a
> > > > href="javascript:choose(9)">9</a></td><td><a
> > > >
> > >
> >
>
href="javascript:choose(10)">10</a></td></tr><tr><td><a
> > > > href="javascript:choose(11)">11</a></td><td><a
> > > > href="javascript:choose(12)">12</a></td><td><a
> > > > href="javascript:choose(13)">13</a></td><td><a
> > > > href="javascript:choose(14)">14</a></td><td><a
> > > > href="javascript:choose(15)">15</a></td><td><a
> > > > href="javascript:choose(16)">16</a></td><td><a
> > > >
> > >
> >
>
href="javascript:choose(17)">17</a></td></tr><tr><td><a
> > > > href="javascript:choose(18)">18</a></td><td><a
> > > > href="javascript:choose(19)">19</a></td><td><a
> > > > href="javascript:choose(20)">20</a></td><td><a
> > > > href="javascript:choose(21)">21</a></td><td><a
> > > > href="javascript:choose(22)">22</a></td><td><a
> > > > href="javascript:choose(23)">23</a></td><td><a
> > > >
> > >
> >
>
href="javascript:choose(24)">24</a></td></tr><tr><td><a
> > > > href="javascript:choose(25)">25</a></td><td><a
> > > > href="javascript:choose(26)">26</a></td><td><a
> > > > href="javascript:choose(27)">27</a></td><td><a
> > > > href="javascript:choose(28)">28</a></td><td><a
> > > > href="javascript:choose(29)">29</a></td><td><a
> > > > href="javascript:choose(30)">30</a></td><td><a
> > > >
> > >
> >
>
href="javascript:choose(31)">31</a></td></tr></FORM></table>
> > > > <TABLE>
> > > > <TR><TH>First_Name</TR>
> > > > <TR><TD>Amos</TR>
> > > > <TR><TD>Jeff</TR>
> > > > <TR><TD>Steve</TR>
> > > > <TR><TD>Cathy</TR>
> > > > <TR><TD>Patricia</TR>
> > > > <TR><TD>Cary</TR>
> > > > <TR><TD>Tom</TR>
> > > > </TABLE>
> > > >
> > > > </body>
> > > > </html>
> > > >
> > > > --- Jim Seach <jwseach@yahoo.com> wrote:
> > > > > I agree - it's worth looking at the client. 
> Do
> > > you
> > > > > have any large
> > > > > tables?  I have had problems in the past
> with
> > > > > Netscape taking a long
> > > > > time (> 5 min) to load tables with several
> > > thousand
> > > > > rows.
> > > > >
> > > > > Jim
> > > > >
> > > > > --- Denis Haskin <Denis@HaskinFerguson.net>
> > > wrote:
> > > > > > Do you know for sure the difference in
> 'load'
> > > time
> > > > > is at the server,
> > > > > > and
> > > > > > not at the client?  What's the content
> coming
> > > back
> > > > > from the server?
> > > > > > I
> > > > > > would grab a copy of that, put it in a
> file,
> > > and
> > > > > load that in IE and
> > > > > > Netscape to see if there's any difference
> in
> > > load
> > > > > times.
> > > > > >
> > > > > > I suppose it's possible that IE and
> Netscape
> > > are
> > > > > sending different
> > > > > > http
> > > > > > headers that are getting handled
> differently
> 
=== message truncated ===


__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

Mime
View raw message