Bill,
        Thanks, I found an errors logged in the JVM.log file which notified me of a problem in the server.xml.  Once this was fixed the logs stopped appearing in the isapi.log file.

Saying all of that when I try to display a *.jsp page I now get HTTP 404 page not found error.
Any Ideas


-----Original Message-----
From: Bruyn, Bill [mailto:Bill.Bruyn@avnet.com]
Sent: Wednesday, 18 July 2001 10:05 AM
To: 'johns@oopl.com.au'
Subject: FW: I'm getting errors when I run JSP's using IIS and TOMCAT


It seems more likely that Tomcat isn't running on the port you have your
worker pointed at (e.g., localhost:8007).  You might consider posting the
entire contents of your log...
 
 
-----Original Message-----
From: Robert Finneran [mailto:rob@digitalskyscrapers.com]
Sent: Tuesday, July 17, 2001 4:57 PM
To: tomcat-user@jakarta.apache.org
Subject: RE: I'm getting errors when I run JSP's using IIS and TOMCAT


Things to check:
 
Be careful that your registry setting are pointing to the right place for
the workers.properties and uriworkermap.properties files.
Look under HKEY_LOCALMACHINE\SOFTWARE\Apache Software Foundation\Jakarta
Isapi Redirector\1.0 for these settings.
 

-----Original Message-----
From: John Sullivan [mailto:johns@oopl.com.au]
Sent: Tuesday, July 17, 2001 4:45 PM
To: tomcat-user@jakarta.apache.org
Subject: I'm getting errors when I run JSP's using IIS and TOMCAT



Hi,
        I'm having problems getting JSP's to run with TOMCAT and IIS.  I've
followed the instructions at Jakarta.apache.org and I've also followed the
instructions at www.verysimple.com/scripts/support_tc_iis.html

Everything appears ok. When I start all the services, Tomcat runs ok, IIS
starts and the redirector appears with a green arrow.  When the services
first start these lines appear in the isapi.log file:

        [jk_uri_worker_map.c (335)]:
jk_uri_worker_map_t::uri_worker_map_close, NULL parameter
        [jk_uri_worker_map.c (185)]: In
jk_uri_worker_map_t::uri_worker_map_free, NULL parameters

I'm assuming that that is OK.  When I call a JSP I then get an IE page
saying

"The Page is unavailable. The page you are looking for is currently
unavailable.
The Web site might be experiencing technical difficulties, or you may need
to adjust your browser settings."

and the following lines in the isapi.log:

[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (152)]: In ::service, Error sd = -1
[jk_isapi_plugin.c (554)]: HttpExtensjk_endpoint_tionProc error, service()
failed
[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
[jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed

I'm assuming that these lines indicate an error.

Does anyome have an idea whats going on here?

Take Care,

John Sullivan