tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitri Colebatch <...@bigpond.net.au>
Subject Re: JSP Setup.
Date Sun, 22 Jul 2001 12:59:14 GMT
someone correct me, but is this the jre not jdk problem.  Tim - what java
package do you have?  Do you have a tools.jar in your classpath?  on
another note, if tomcat through 8080 doesn't work, then apache-tomcat
definately wont....

cheesr
dim

On Sat, 21 Jul 2001, Tim Ashman wrote:

> If I run it through port 8080 ie.      serverhost:8080 then I get the 
> following error in the browser.  Thanks for your help.
> 
> Error: 500
> Location: /examples/jsp/snp/snoop.jsp
> Internal Servlet Error:
> 
> javax.servlet.ServletException: sun/tools/javac/Main
> 	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:399)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> 	at org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:404)
> 	at org.apache.tomcat.core.Handler.service(Handler.java:286)
> 	at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
> 	at 
> org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)
> 	at org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
> 	at 
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)
> 	at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
> 	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
> 	at java.lang.Thread.run(Thread.java:484)
> 
> 
> 
> Dmitri Colebatch wrote:
> 
> > Where are the jsps?  As long as they're not in apache's docroot (or subdir
> > thereof) then apache wont process them.  I'm also assuming that you can
> > get the jsps working fine in localhost:8080 (ie., directly through
> > tomcat).
> > 
> > cheers
> > dim
> > 
> > On Sat, 21 Jul 2001, Tim Ashman wrote:
> > 
> > 
> >>Ok, I think I've got apache passing the .jsp's to tomcat.  I can run 
> >>some of the example jsp's,  The ones that start with .html files.  But 
> >>when I do a submit the browser just shows the page source instead of 
> >>actually running the jsp.  I have my servlet directory working the same 
> >>way.
> >>
> >>Does anyone have a clue as to what might be going wrong?  My gut 
> >>instinct is that apache is still handling the jsp's and hence I get html 
> >>back.
> >>
> >>Thanks.
> >>
> >>John Hebert wrote:
> >>
> >>
> >>>Tim Ashman wrote:
> >>>
> >>>
> >>>>I'm new to Tomcat and have Tomcat and apache playing together.  I've

> >>>>been able to create servlets, and have them successfully run.  I am 
> >>>>now trying to learn JSP but when I put the *.jsp files onto the server

> >>>>I can't get them to run.  I receive 404 errors.  I've looked though 
> >>>>the online help, etc and most of it seems a little confusing.
> >>>>
> >>>>Am I just placing the .jsp's in the wrong place?  Do I need some .jar

> >>>>files that don't come with the standard java/tomcat installs?
> >>>>
> >>>
> >>>Sounds like they are either in the wrong place or Apache is not 
> >>>configured to point to the correct place. The jasper.jar is the jar file

> >>>that handles .jsp's. Need more info in order to help you further, 
> >>>specifically config info (httpd.conf, server.xml).
> >>>
> >>>
> >>>
> >>
> >>
> > 
> > 
> 
> 
> 


Mime
View raw message