tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Blessing" <>
Subject errors using Tomcat w/ IIS 5.0
Date Mon, 02 Jul 2001 23:23:34 GMT
Hi there-

I'm running Windows 2000 w/ IIS 5.0.  I've configured the webserver with the
appropriate /jakarta virtual dir, entered the correct registry settings and
all, and properly setup the and
files.  I was reading the IIS How-To page and went through all the steps.

So I finally get the green arrow I've been waiting for and go to request
http://localhost/examples/jsp/index.html but it errors on me.  I check the
IIS log and the last line(s) is/are:

23:17:19 GET /jakarta/isapi_redirect.dll 500

So then I check the Tomcat log file (set to "debug" in registry) and I find
this (I removed the initial log lines related to the IIS startup/ISAPI

[jk_isapi_plugin.c (408)]: HttpFilterProc started
[jk_isapi_plugin.c (429)]: In HttpFilterProc test redirection of
[jk_uri_worker_map.c (345)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (407)]: jk_uri_worker_map_t::map_uri_to_worker, Found a
match ajp12
[jk_isapi_plugin.c (439)]: HttpFilterProc [/examples/jsp/index.html] is a
servlet url - should redirect to ajp12
[jk_isapi_plugin.c (461)]: HttpFilterProc check if
[/examples/jsp/index.html] is points to the web-inf directory
[jk_isapi_plugin.c (517)]: HttpExtensionProc started
[jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
[jk_worker.c (127)]: wc_get_worker_for_name, done  found a worker
[jk_isapi_plugin.c (539)]: HttpExtensionProc got a worker for name ajp12
[jk_ajp12_worker.c (223)]: Into jk_worker_t::get_endpoint
[jk_ajp12_worker.c (121)]: Into jk_endpoint_t::service
[jk_connect.c (108)]: Into jk_open_socket
[jk_connect.c (115)]: jk_open_socket, try to connect socket = 1760
[jk_connect.c (124)]: jk_open_socket, after connect ret = -1
[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (134)]: In jk_endpoint_t::service, sd = -1
[jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
[jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
[jk_ajp12_worker.c (163)]: Into jk_endpoint_t::done

Note, again, that this log excerpt is only in relation to the HTTP request,
not the startup of the ISAPI filter.

So basically I'm wondering if someone can tell me what errno 61 is, and why
this is failing on me.  I've tried everything in the troubleshooting section
of the IIS How-To page and nothing's worked yet. =(

TIA for any help you can offer, I'm stuck!

-Chris Blessing

View raw message