tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Einspanjer <daniel...@yipyip.com>
Subject Xalan 2.1.0 & Tomcat 3.2.2 conflict
Date Tue, 17 Jul 2001 17:29:43 GMT
I just put the Xalan 2.1.0 package on our testing webserver running Tomcat 3.2.2, and ran into
some problems.

Specifically, jaxp.jar and possibly parser.jar in the tomcat/lib conflict with Xalan.
When trying to use the javax.xml.parsers.DocumentBuilder.parse() method, the parse will throw
a SAXException if you pass in a URI instead of a file and the file to be parsed has relative
external entities.
When trying to use the org.apache.xpath.XPathAPI.selectNodeIterator() method, bad things happened
in the org.apache.xpath.axes.AxesWalker. One problem was that the getNextNode() method was
not found, and unfortunately, I've forgotton what the other error was. :/

Anyway, I resolved my problems by removing jaxp.jar and parser.jar from the tomcat/lib directory
and depending on tomcat finding the xalan.jar and xerces.jar in my classpath.

HTH someone.
-- Daniel Einspanjer, daniel@yipyip.com on 7/17/2001


Mime
View raw message