tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tia Haenni" <thae...@kc.rr.com>
Subject RE: Upgrading tomcat
Date Fri, 27 Jul 2001 02:12:41 GMT
Well, then, what am I waiting for? Thanks for the input.

Tia

-----Original Message-----
From: Craig R. McClanahan [mailto:craigmcc@apache.org]
Sent: Thursday, July 26, 2001 6:53 PM
To: tomcat-user@jakarta.apache.org
Subject: Re: Upgrading tomcat




On Thu, 26 Jul 2001, Charles Baker wrote:

> Another question, do apps developed under the 3.2.x (
> jsp 1.1/servlet 2.2 ) work well with Tomcat 4.0 and
> the newer servlet/jsp specs?
> 

The servlet 2.3 and JSP 1.2 specs *require* backwards compatibility, even
to the point of requiring 2.3/1.2 containers to recognize valid 2.2/1.1
deployment descriptors and tag libraries.  In addition, no
non-backwards-compatible API changes were made.

Therefore, as long as your app does not rely on:

* Non-spec features of Tomcat 3.2 that are different in
  Tomcat 4.0.

* Areas where the 2.2/1.1 specs were silent and the 2.3/1.2
  specs have created some specific behavior that is different
  than what Tomcat 3.2 did.

* Bugs in Tomcat 3.2.

then you should be fine.  In practice, I have found *very* few cases where
I bumped into any of these issues.  Just as one simple example of this,
all of the web applications shipped with Struts
<http://jakarta.apache.org/struts/> run just fine under both 3.2 and 4.0.

Craig McClanahan


Mime
View raw message