tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pär-Joel Utsi <pju...@spincord.com>
Subject redirect problems?
Date Fri, 06 Jul 2001 07:52:22 GMT
Hello Tomcat/Jakarta/Apache

I am experiencing some weird problems with my web server setup.
My system configuration is:

Windows 2000 server
IIS 5.0
Jakarta Tomcat 3.2.2
MS SQL 2000
Avenir aveConnect JDBC-driver 2.4M (developer verison)

I have built an "insert post" page in MM Dreaweaver Ultradev 4.0 with a
standard html form (texfields and a submitm button) and a jdbc connection.
After the submit button is activated and the form data is inserted (which
works great) I have added an jsp redirect command, and it is here the
weirdness starts.

The redirect function (
response.sendRedirect(response.encodeRedirectURL(MM_editRedirectUrl)); )
doesn't seem to work if the page contains a lot of html code. 

With only the form tags <body><form>...</form></body> the redirect-command
works just fine.

But when nestling the form tag with tables and other formatting html code
the redirect seems to break down. After pressing the submit button, the URL
changes as it should and the new page is displayed, only BELOW parts of the
old (form) page. How much of the old page that is included after the
redirect-command is dependent on the amount of html code ob the form page.

Does this make any sense at all? I have spent 3 days trying back and forth
with tomacat conf-files and IIS settings and so on.

Best regards, PJ Utsi - Gothenburg Sweden

Mime
View raw message