tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Layman <randy.lay...@aswethink.com>
Subject RE: Urgent Help with Tomcat 4.0
Date Mon, 09 Jul 2001 11:03:18 GMT

	First, only use plain email messages, not HTML or Rich Text Format -
many list readers can't deal with the more complex messages, thus limiting
your audience.

	Second, it seems to me like you have an old version of servlet.jar
in your classpath.  If you have Tomcat 3.2 in the classpath this could cause
the problem.  Also, JBuilder or other IDEs could cause you the problem.

	Randy

-----Original Message-----
From: TIMBMS@aol.com [mailto:TIMBMS@aol.com]
Sent: Sunday, July 08, 2001 6:42 PM
To: tomcat-user@jakarta.apache.org
Subject: Urgent Help with Tomcat 4.0


Hi there 
i downloaded Tomcat 4.0 b5 and installed it on my PC running win98. it works

fine but for some reason it does not run the jsp examples in the local host 
or any other jsp pages i created, even though it runs the servlets ok. i get

the error shown below 

A Servlet Exception Has Occurred 

org.apache.jasper.JasperException: Unable to compile class for 
JSPC:\Tomcat\bin\..\work\localhost\examples\jsp\dates\date_jsp.java:168: 
Incompatible type for method. Explicit cast needed to convert 
java.lang.Throwable to java.lang.Exception. 
       if (pageContext != null) pageContext.handlePageException(t); 
                                                                ^ 
1 error 

at org.apache.jasper.compiler.Compiler.compile(Compiler.java:277) 
...etc 

any suggestions ? thanx Tim 

Mime
View raw message