tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eoin Woods <wo...@intertrust.com>
Subject RE: PoolMan woes
Date Tue, 03 Jul 2001 21:20:46 GMT
> Method getDataSource(java.lang.String) not found in class
com.codestudio.sql.PoolMan

I use findDataSource(java.lang.String) - although both are documented in the
JavaDoc.

Is poolman.jar in your CLASSPATH when you compile?  I've just tested this
with 2.0.1 and both findDataSource() and getDataSource() are found.

Cheers,

Eoin.
-----Original Message-----
From: Matt Barre [mailto:mbarre@digiterra.com]
Sent: Tuesday, July 03, 2001 1:47 PM
To: Eoin Woods; tomcat-user@jakarta.apache.org
Subject: Re: PoolMan woes


Thanks for the tip. By taking the two suggestions I now have Tomcat somewhat
stabilized. I
am working on a jsp to get all the kinks worked out. I import the PoolMan
packages but I
get the following/weird error:

Method getDataSource(java.lang.String) not found in class
com.codestudio.sql.PoolMan

According to the javadocs that is a valid function call
Any further ideas?

Thanks,

Matt
----- Original Message -----
From: "Eoin Woods" <woods@intertrust.com>
To: <tomcat-user@jakarta.apache.org>
Cc: <mbarre@digiterra.com>
Sent: Tuesday, July 03, 2001 1:18 PM
Subject: RE: PoolMan woes


> We're using PoolMan 2.0.x with Tomcat 3.2.x without too many problems.
>
> PoolMan does respond rather violently when it can't find its configuration
> file - which is "poolman.xml" in version 2.  I put this in
> $TOMCAT_HOME/classes and it appears to be found OK.
>
> If PoolMan doesn't find its configuration file, it ends up throwing a
> NullPointerException however, I've never seen this floor Tomcat - you just
> get an exception in the logs.
>
> How are you using PoolMan from within Tomcat?  We just import it into our
> servlets and call PoolMan.findDataSource("MyDataSource") to retrieve a
data
> source from it and then call ds.getConnection() to force initialisation.
>
> One difference is that we're on Solaris with JDK 1.3.1 and you have a W2K
> JVM.
>
> Eoin.
> -----Original Message-----
> From: Matt Barre [mailto:mbarre@digiterra.com]
> Sent: Tuesday, July 03, 2001 11:25 AM
> To: tomcat-user@jakarta.apache.org
> Subject: PoolMan woes
>
>
> I am trying to get PoolMan and TomCat to play nicely together.
> I am developing on Win2k, Tomcat 3.2.
>
> My first attempt was to use version 2.0.4 of Poolman with Tomcat
3.2...upon
> access
> PoolMan.jsp, Tomcat stops running. No errors, no warnings, its terminal
> window just
> vanishes. I tried increasing the heap size, but that didn't seem to help.
>
> Next I tried installing PoolMan 1.4.1. This doesn't crash TomCat but
> mysteriously it can't
> find its poolman.props file. I've tried putting it in directories that I'm
> absolutely
> positive are in my ClassPath without luck.
>
> I've read the docs pretty extensively I think, but can't seem to come up
> with an answer.
> My overall goal is to simply add connection pooling to tomcat. If anyone
can
> give me some
> pointers, thanks in advance.
>
> Matt

Mime
View raw message