tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pankaj Chhaparwal <pchhapar...@Houston.GeoQuest.SLB.COM>
Subject RE: mod_jserv in Tomcat3.2.2 on Solaris
Date Mon, 23 Jul 2001 06:24:35 GMT
Hi ,
I was using version 1.2.2. I tried with version 1.3 also but got the same 
error.

Thanks,
Pankaj

At 01:41 AM 7/23/2001 -0400, you wrote:
>Hi,
>Don't know if this will work, but check your java version. Make sure it's 
>above 1.3 if not you can download a new version from sun. It looks like you
>are using the default java install on a sparc box.
>
>Jay
>
> > Hi,
> >
> > I am getting the following error.
> >
> >
> > pxs -o mod_jk.so -DSOLARIS -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -c *.c ../jk/*.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c mod_jk.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_ajp12_worker.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_ajp13.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_ajp13_worker.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_connect.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_jni_worker.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_lb_worker.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_map.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_msg_buff.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_nwmain.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_pool.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_sockbuf.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_uri_worker_map.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_util.c
> > gcc -DSOLARIS2=280 -DUSE_EXPAT -I../lib/expat-lite
> > -DNO_DL_NEEDED  -I/home/mkumar/Apache/include -I../jk -I/usr/java/include
> > -I/usr/java/include/solaris -DSOLARIS  -c ../jk/jk_worker.c
> >    -o mod_jk.so jk_worker.o jk_util.o jk_uri_worker_map.o jk_sockbuf.o
> > jk_pool.o jk_nwmain.o jk_msg_buff.o jk_map.o jk_lb_worker.o 
> jk_jni_worker.o
> > jk_connect.o jk_ajp13_worker.o jk_ajp13.o jk_ajp12_worker.o mod_jk.o
> > apxs:Break: Command failed with rc=16711680
> >
> > The compilation of the c files is being done but the the the .so file is
> > not getting created with the .o files. The same problem is coming with
> > mod_serv.I am using source of tomcat3.2.3. Any help on this will be 
> greatly
> > appreciated.I am doing the build in tcsh.
> >
> > Regards,
> > Pankaj
> >
> >
> > At 09:44 AM 7/23/2001 +1200, John Bazeley wrote:
> > >john@ecnetwork.co.nz
> >
> >
> >
>
>James Hester
>www.apocalypse-zone.com
>apocalypse@apocalypse-zone.com



Mime
View raw message