tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul D. Bain" <paul_b...@bigfoot.com>
Subject Re: help with compiling mod_jk
Date Sat, 14 Jul 2001 21:36:00 GMT
At Saturday 7/14/01 11:16 AM , you wrote:
>Hi.  I am trying to configure Apache(2.0.16) on my linux system 

        My understanding is that Apache modules written for Apache 1.3 (such as
mod_jk) cannot be made to work with the new Apache, version 2.x. In order to
run with the new Apache, an Apache module must be rewritten, and I suspect that
mod_jk has not yet been rewritten.

> (redhat 
>7.1) with tomcat (3.2).  According to tomcat's documentation, I should 
>try to compile my own mod_jk module by downloading the source for 
>jakarta-tomcat.  I downloaded it and then I ran the command as per 
>documentation:
>
>apxs -o mod_jk.so -I../jk -I/usr/local/jdk/include  
>-I/usr/local/jdk/include/linux -c *.c ../jk/*.c
>
>I have adjusted the java path accordingly so that it reflects $JAVA_HOME 
>on my system.  However when I ran this command, I get the following errors:
>
>libtool --silent --mode=compile gcc -pthread 
>-I/usr/local/apache2/include -I../jk -I/usr/local/java/include 
>-I/usr/local/java/include/linux  -c mod_jk.c && touch mod_jk.slo
>mod_jk.c:76:31: http_conf_globals.h: No such file or directory
>apxs:Break: Command failed with rc=65536
>
>It says that it can't find the http_conf_globals.h file but I couldn't 
>find it on my system even after doing a search.
>
>Please help.  Thanks,
>Michael.
>

Mime
View raw message