tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hebert <j...@vedalabs.com>
Subject Re: apj13 not working
Date Wed, 25 Jul 2001 14:17:21 GMT
What's your classpath look like?

John

isleofdogs wrote:

> My system: Tomcat/Apache+mod_ssl/RedHat 7.1
> 
> -------------------[Howto snippet]----------------------------------
> 
> mod_jk can use either the original Ajpv12 protocol or the newer Ajpv13
> protocol. Both protocols are enabled by default. The "Ajp13" Connection
> Handler in Tomcat will give you the
> benefit of a faster protocol and the ability to identify requests made via
> HTTPS.
> 
> The following block enables Ajpv13 in your TOMCAT_HOME/conf/server.xml file. 
> 
> <RequestInterceptor
> className="org.apache.tomcat.modules.server.Ajp13Interceptor"
> port="8009"/>
> 
> -------------------[Howto snippet]----------------------------------
> 
> According to this, I can just put this block in with the
> rest of the Interceptors. I made sure not to put it after
> the LoadOnStartupInterceptor which loads last.
> 
> When I do, I get the following at startup:
> 
> ERROR reading /usr/local/jakarta/jakarta-tomcat-3.2.3/conf/server.xml
> At Line 188 /Server/ContextManager/RequestInterceptor/
> className=org.apache.tomcat.modules.server.Ajp13Interceptor port=8009
> 
> FATAL: configuration error
> java.lang.ClassNotFoundException:
> org.apache.tomcat.modules.server.Ajp13Interceptor
> 
> 
> 
> 
> This installation works fine with Ajp12.
> Am I missing something?
> Why is Ajp12 an Interceptor while Ajp12 is Connector?



-- 
John Alex Hebert
john@vedalabs.com
System Engineer

Mime
View raw message