tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gary.d...@mail1.moh.gov.on.ca (Gary Dale)
Subject server.xml settings for virtual hosts
Date Tue, 24 Jul 2001 19:47:57 GMT
I'm running Apache 1.3.20 and Tomcat 3.2.2 with JDK1.3.1 on an NT box. 
Both Apache and Tomcat are running as services. I am able to run the 
examples with and without Apache so my basic setup is OK.

According to the "working with mod_jk" document (under Configuring 
Tomcat), I have to add an <ApacheConfig /> entry to server.xml to 
generate the Apache autoconfiguration file (presumably 
mod_jk.conf-auto). However, I can't find the <AutoWebApp ... /> entry 
refered to in the documentation.

None the less, a mod_jk.conf-auto is created each time I start Tomcat. 
However, it ignores the entries I put into server.xml for virtual hosts 
and only generates contexts for subdirectories  it finds in webapps. I 
can add a directory to webapps and it adds it to the .conf-auto. When I 
remove it again, it is removed from .conf-auto.

 It also ignores the entry I put in for Ajp13.

My server.xml changes are similar to the ones shown in Table 1 of the 
"working with mod_jk" document and the comments in the server.xml file. 
The Ajp13 connector is a cut and paste of the Ajp12 connector with the 
values changed. The virtual hosts are similar to the examples only with 
the name and docBase adjusted to fit my server. This is moot since it 
seems to be ignoring the changes anyway.

Can someone provide some insight into how I can get Tomcat to generate 
the mod_jk.conf-auto file with Ajp13 and the virtual hosts I specify?



Mime
View raw message