tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Dzmura <...@digital-mission.com>
Subject Help w/ Tomcat 4.0b6 and Apache
Date Tue, 24 Jul 2001 17:45:42 GMT
Folks:

I have received but a single response to my multiple posts
regarding Tomcat 4 Beta 6 and Apache, but, alas, it, was not helpful.
Given the otherwise high level of activity on this list, I must again ask
this question:

"Is anybody on this list successfully using Tomcat 4 with Apache??"

If so, I would desperately like to know your configuration and see the relevant
parts of your server.xml, apache configs, and know what module/version you
are using as bridge between Apache and Tomcat.

Our desired benchmark is simply to achieve the same behaviors from the example
JSP's through port 80 (via Apache) as we do through port 8080.

It has taken enormous effort just to get something limping along, but still
the transport between Apache and Tomcat (mod_webapp) is clearly broken -
key header variables have default values instead of actual values,
preventing the application from using sessions or accessing the proper
values of header variables.

As an example, the "snoop" JSP provides reasonable values when executed
from port 8080 but reports mostly null's and -1's, when executed from port 80.

We are using the latest versions of everything - Tomcat milestone 4.0b6,
apr, and mod_webapp CVS snapshot.  We have tried using the Java Warp code that
comes with Tomcat, and replacing it with the Java part of the mod_webapp build.

I have also rebuilt mod_webapp with --enable-debug and see NO DIFFERENCE
WHATSOEVER in the log contents.

Any ideas at all would be appreciated.  If I don't get any responses I will
have to conclude that nobody is actually using Tomcat 4.  However, I find it
difficult to justify that conclusion for a distribution in its 6th Beta!!

Thanks,

Mark

--
Mark Dzmura
Digital Mission LLC




Mime
View raw message