tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian McSweeney <Brian.McSwee...@cs.tcd.ie>
Subject Please,please can you help me?
Date Wed, 18 Jul 2001 11:32:04 GMT
Hi everyone,
I have had a problem with trying to run a security manager in
Apache-Soap for days. I'm running Tomcat3.2.2 and using soap 2-2 and
xerces 1_4_1. However the inclusion of xerces causes an error when I try
to run Tomcat with a security manager. It all works fine otherwise.
Without xerces I can run a security manager with Tomcat, and with xerces
I can run Tomcat without a security manager. However with xerces and a
security manager when I try to run Tomcat I get this error. I would be
indebted forever if someone could help me. I've tried both windows 98
and Solaris - same error.
Brian

> Exception in thread "main" java.lang.ExceptionInInitializerError:
> java.security.AccessControlException: access denied

> (java.util.PropertyPermission jaxp. debug read)
>         at
>
java.security.AccessControlContext.checkPermission(AccessControlContext.java:272)

>         at
>
java.security.AccessController.checkPermission(AccessController.java:399)

>         at
> java.lang.SecurityManager.checkPermission(SecurityManager.java:545)
>         at
>
java.lang.SecurityManager.checkPropertyAccess(SecurityManager.java:1278)

>         at
> java.lang.System.getProperty(System.java:560)
>         at
> javax.xml.parsers.SAXParserFactory.<clinit>(SAXParserFactory.java:270)

>         at
> org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:210)
>         at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:187)
>         at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:235)




Mime
View raw message