tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hochberg, Lincoln" <Lincoln.Hochb...@mlb.com>
Subject RE: jasper errors
Date Wed, 18 Jul 2001 14:57:00 GMT
Solved.  The problem was that I had that java was running from jdk1.1.  As
soon as I mapped it to jdk1.3 everything worked fine.

Linc

Lincoln Hochberg
 <http://www.mlb.com/> 
 212-485-3721
 lincoln.hochberg@mlb.com <mailto:lincoln.hochberg@mlb.com> 


	-----Original Message-----
	From:	Hochberg, Lincoln [SMTP:Lincoln.Hochberg@mlb.com]
	Sent:	Tuesday, July 17, 2001 5:03 PM
	To:	'tomcat-user@jakarta.apache.org'
	Subject:	jasper errors

	Hi, I've been having problems getting jasper to run properly.  I
downloaded
	the 3.2.3 version of Tomcat to a box with Solaris 2.6.  I am trying
to run
	something like the following:

	java -classpath .:$HOME/lib/jasper.jar:$HOME/lib/webserver.jar
	org.apache.jasper.JspC -v4 -webapp docroot

	I get the following output from that command:
	2001-07-17 13:52:27 - Package name is: [default package]
	2001-07-17 13:52:27 - Class file name is:
	
/iwmnt/default/main/mlb_1/source/WORKAREA/lhochberg/htdocs//_0002findex_0002
	ejspindex.class
	2001-07-17 13:52:27 - Java file name is:
	
/iwmnt/default/main/mlb_1/source/WORKAREA/lhochberg/htdocs//index.java
	2001-07-17 13:52:27 - Class name is: index
	Unknown object of type:java.util.Hashtable
	Unknown object of type:java.lang.IllegalArgumentException
	java.lang.IllegalArgumentException: Unknown argument
	        at java.text.MessageFormat.format(MessageFormat.java)
	        at java.text.MessageFormat.format(MessageFormat.java)
	        at java.text.Format.format(Format.java)
	        at org.apache.jasper.Constants.getString(Constants.java:211)
	        at org.apache.jasper.Constants.message(Constants.java:247)
	        at org.apache.jasper.JspC.parseFile(JspC.java:412)
	        at org.apache.jasper.JspC.parseFiles(JspC.java:641)
	        at org.apache.jasper.JspC.main(JspC.java:689)

	I thought that maybe it was missing Hashtable and other classes in
the
	classpath but when I added rt.jar to the classpath I get a
segmentation
	fault:
	SIGSEGV   11*  segmentation violation
	    si_signo [11]: SIGSEGV   11*  segmentation violation
	    si_errno [0]: Error 0
	    si_code [1]: SEGV_ACCERR [addr: 0x0]


	Full thread dump:
	Segmentation Fault

	Does anybody know what's going on here?

	Thanks,
	Linc

	Lincoln Hochberg
	 <http://www.mlb.com/> 
	 212-485-3721
	 lincoln.hochberg@mlb.com <mailto:lincoln.hochberg@mlb.com> 


	
============================================================================
==
	"WorldSecure Server <mlbaseball.com>" made the following
	 annotations on 07/17/01 17:08:21
	
----------------------------------------------------------------------------
----------------------------------------------------------------------------
----
	[INFO] -- Virus Manager:
	No Viruses were detected in this message.

	
============================================================================
==

Mime
View raw message